Opened 14 years ago

Closed 9 years ago

#62 closed defect (fixed)

Unbreak phpMyAdmin

Reported by: andersk Owned by:
Priority: major Milestone:
Component: sql Keywords:
Cc:

Description

The phpMyAdmin installation(s) in the sql locker are old and somewhat screwed up. geofft was going to fix this but he went to sleep, so I’m recording the necessary steps here as a reminder.

  • svn co https://phpmyadmin.svn.sourceforge.net/svnroot/phpmyadmin/tags/STABLE/phpMyAdmin
  • Copy config.sample.inc.php to config.inc.php.
    • Set $cfg['blowfish_secret'] to a secure random value.
    • Set $cfg['Servers'][$i]['host'] = 'sql.mit.edu'
    • Set $cfg['Servers'][$i]['extension'] = 'mysqli'
    • Set $cfg['ForceSSL'] = TRUE
  • Copy /etc/php.ini to php.ini.
    • Add the mcrypt and mysqli extensions.

The patches and .htaccess redirect are then unnecessary, and future upgrades will be as simple as svn up. (Example: <https://andersk.scripts.mit.edu/phpMyAdmin/>.)

Attachments (1)

ssl_bad_cert.png (62.4 KB) - added by presbrey 14 years ago.

Download all attachments as: .zip

Change History (13)

Changed 14 years ago by presbrey

comment:1 Changed 14 years ago by presbrey

Changed to SVN version though older version had no issues.

Patches are still necessary. On yours, choose "Databases" from the bottom of the main.php screen (or toolbar of any other screen) and then select a database from the list instead of the side pane. The correct behavior is to update the side pane with the database selected and then show its structure or properties in the main pane. Yours does not do this.

The snapshot I attached is probably related to my beta browser but weird just the same.

comment:2 Changed 14 years ago by quentin

The issue that users are seeing is that they sometimes can't authenticate to phpMyAdmin. I don't know what the root cause is, but it seems server-specific. Perhaps there's a cookie they're getting that's server-specific?

comment:3 Changed 14 years ago by andersk

  • Priority changed from major to minor

Hmm, I’m not sure what’s up with the cert error; I get the right certificate with Firefox 3.0b4 on Linux.

Anyway, thanks, this seems to have fixed the login problem. There are some other problems with the config file though. I think you should delete the entire block of PmaAbsoluteUri? through ShowBlob? settings, with the exception of blowfish_secret and ForceSSL. The defaults work fine, and at least three of these settings are problematic (PmaAbsoluteUri? causes breakage when you access the site from other URLs; lang and Lang force the use of an obsolete character set instead of autodetecting the right one).

I see what you mean with the database selection bug. Has this been reported upstream?

comment:5 Changed 14 years ago by andersk

  • Priority changed from minor to major

A user confirms that copying, exporting, and importing are broken in the new sql-patched install but work in my vanilla install. I think this implies that the patches have bitrotted and are now doing more harm than good. The patches and config changes should be reverted. I recommend that if any new patches are produced, they should be submitted upstream as soon as possible.

comment:6 Changed 12 years ago by adehnert

Ermm... Is still... relevant? It's been two years, and cursory checking suggests that https://scripts.mit.edu/~sql/phpMyAdmin/ does work.

comment:7 Changed 10 years ago by adehnert

Well, nobody tried to claim it *was* still relevant, so I'm guessing it isn't. (Also, cursory checking continues to suggest that.)

comment:8 Changed 10 years ago by ezyang

  • Milestone set to Fedora 15

Copying, exporting and importing are still broken. We should fix this. (Databases selection bug appears to be fixed.)

comment:9 Changed 10 years ago by ezyang

  • Priority changed from normal to major

comment:10 Changed 10 years ago by ezyang

  • Milestone changed from Fedora 15 to Fedora 17

Not a release blocker, remilestoning.

comment:11 Changed 10 years ago by ezyang

  • Milestone Fedora 17 deleted

comment:12 Changed 9 years ago by achernya

  • Resolution set to fixed
  • Status changed from new to closed

We've moved to the git checkout of phpMyAdmin, and the scripts changes are now encapsulated in a single commit that we should be able to rebase around as necessary.

It's unclear if ForceSSL is a good idea, as it's not included in config.sample.inc.php, but this shouldn't be necessary as we now have a RewriteRule? redirecting to HTTPS.

Note: See TracTickets for help on using tickets.