Opened 12 years ago

Closed 11 years ago

#179 closed defect (fixed)

resolv.conf gets overwritten on reboot

Reported by: ezyang Owned by:
Priority: normal Milestone:
Component: internals Keywords:
Cc:

Description

Maybe this is because NetworkManager? is installed for some strange reason?

Change History (2)

comment:1 Changed 11 years ago by achernya

This still exists on Fedora 15. How bad would it be to

chattr -i resolv.conf

comment:2 Changed 11 years ago by achernya

  • Resolution set to fixed
  • Status changed from new to closed

On Fedora 15, the culprit was ifcfg-eth0 specifying DNS servers, whichi is usually caused by Anaconda saving the install-time configuration. Removing these clauses causes resolv.conf to be untouched.

Note: See TracTickets for help on using tickets.