Changeset 2400


Ignore:
Timestamp:
Apr 26, 2013, 9:59:11 PM (8 years ago)
Author:
achernya
Message:
rubygems 1.8.25-6
File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/server/fedora/specs/rubygems.spec.patch

    r2390 r2400  
    1 --- rubygems.spec.orig  2013-03-19 19:40:59.590767463 -0400
    2 +++ rubygems.spec       2013-03-19 21:13:12.458970873 -0400
    3 @@ -15,7 +15,7 @@
    4  
    5  # Executing testsuite (enabling %%check section) will cause dependency loop.
    6  # To avoid dependency loop when necessary, please set the following value to 0
    7 -%global        enable_check    1
    8 +%global        enable_check    0
    9  
    10  # It cannot be relied on %%{_libdir} for noarch packages. Query Ruby for
    11  # the right value.
     1--- rubygems.spec.orig  2013-04-05 15:02:08.147935906 -0400
     2+++ rubygems.spec       2013-04-05 15:04:14.512566960 -0400
    123@@ -26,7 +26,7 @@
    134 Summary:       The Ruby standard for packaging ruby libraries
    145 Name:          rubygems
    156 Version:       1.8.25
    16 -Release:       4%{?dist}
    17 +Release:       4%{?dist}.scripts.%{scriptsversion}
     7-Release:       6%{?dist}
     8+Release:       6%{?dist}.scripts.%{scriptsversion}
    189 Group:         Development/Libraries
    1910 License:       Ruby or MIT
    2011 
    21 @@ -60,12 +60,15 @@
     12@@ -60,6 +60,8 @@
    2213 # https://github.com/rubygems/rubygems/issues/210
    2314 Patch109:      rubygems-1.8.11-binary-extensions.patch
     
    2819 Requires:      ruby(abi) = 1.9.1
    2920 Requires:      rubygem(rdoc) >= 3.9.4
    30  Requires:      rubygem(io-console) >= 0.3
    31  Requires:      ca-certificates
    32  BuildRequires: ruby(abi) = 1.9.1
    33 +BuildRequires: ruby
    34  %if %{enable_check}
    35  # For mkmf.rb
    36  BuildRequires: ruby-devel
    37 @@ -105,6 +108,8 @@
     21@@ -105,6 +107,8 @@
    3822 %patch105 -p1 -b .uninst
    3923 %patch109 -p1 -b .bindir
Note: See TracChangeset for help on using the changeset viewer.