source: branches/fc15-dev/server/fedora/specs/ghc-unix-handle.spec @ 1826

Last change on this file since 1826 was 1826, checked in by achernya, 13 years ago
Get ghc packages to build on F15 Regenerated the .spec files with cabal2spec for the Haskell packages that are needed by Scripts, including bumping the versions to the latest ones.
File size: 2.0 KB
RevLine 
[1826]1# For Haskell Packaging Guidelines see:
2# - https://fedoraproject.org/wiki/Packaging:Haskell
3# - https://fedoraproject.org/wiki/PackagingDrafts/Haskell
4
[1590]5%global pkg_name unix-handle
6
[1826]7# common part of summary for all the subpackages
[1693]8%global common_summary Haskell %{pkg_name} library
[1590]9
[1826]10# main description used for all the subpackages
[1693]11%global common_description A %{pkg_name} library for Haskell.
12
[1826]13# Haskell library dependencies (used for buildrequires and devel/prof subpkg requires)
[1693]14#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
15
[1826]16# foreign library dependencies (used for buildrequires and devel subpkg requires)
[1693]17#%%global ghc_pkg_c_deps @CDEP1@-devel
18
[1590]19Name:           ghc-%{pkg_name}
20Version:        0.0.0
21Release:        0.%{scriptsversion}%{?dist}
[1693]22Summary:        %{common_summary}
[1590]23
[1693]24Group:          System Environment/Libraries
[1826]25License:        @LICENSE@
26URL:            http://hackage.haskell.org/package/%{pkg_name}
[1590]27Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
28# fedora ghc archs:
[1826]29ExclusiveArch:  %{ix86} x86_64 ppc alpha sparcv9
[1693]30BuildRequires:  ghc, ghc-doc, ghc-prof
[1826]31# macros for building haskell packages
32BuildRequires:  ghc-rpm-macros >= 0.7.3
33BuildRequires:  hscolour
[1693]34%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
35%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
[1590]36
37%description
[1693]38%{common_description}
[1590]39
40
41%prep
42%setup -q -n %{pkg_name}-%{version}
43
44
45%build
[1693]46%ghc_lib_build
[1590]47
48
49%install
[1693]50%ghc_lib_install
[1590]51
52
[1826]53# define the devel and prof subpkgs, devel post[un] scripts, and filelists:
54# ghc-%pkg_name{,devel,prof}.files
55%ghc_lib_package
[1590]56
57
58%changelog
[1826]59* Sat Apr 30 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0
60- regenerated packaging for Fedora automatically generated by cabal2spec-0.22.5
61
[1693]62* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
63- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.