Ignore:
Timestamp:
Oct 23, 2010, 8:07:08 AM (13 years ago)
Author:
ezyang
Message:
Merge Fedora 13 development back to trunk.
Location:
trunk
Files:
3 edited

Legend:

Unmodified
Added
Removed
  • trunk

  • trunk/server/fedora

    • Property svn:ignore set to
      .dload
      download_stamp
      rpmbuild
  • trunk/server/fedora/specs/ghc-unix-handle.spec

    r1590 r1693  
    11%global pkg_name unix-handle
    22
    3 %bcond_without doc
    4 %bcond_without prof
     3%global common_summary Haskell %{pkg_name} library
    54
    6 # ghc does not emit debug information
     5%global common_description A %{pkg_name} library for Haskell.
     6
     7# add any Haskell library dependencies here:
     8#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
     9
     10# add any foreign library dependencies here:
     11#%%global ghc_pkg_c_deps @CDEP1@-devel
     12
     13%bcond_without shared
     14
     15# debuginfo is not useful for ghc
    716%global debug_package %{nil}
    817
     
    1019Version:        0.0.0
    1120Release:        0.%{scriptsversion}%{?dist}
    12 Summary:        Haskell %{pkg_name} library
     21Summary:        %{common_summary}
    1322
    14 Group:          Development/Libraries
     23Group:          System Environment/Libraries
    1524License:        BSD
    1625URL:            http://hackage.haskell.org/cgi-bin/hackage-scripts/package/%{pkg_name}
     
    1928# fedora ghc archs:
    2029ExclusiveArch:  %{ix86} x86_64 ppc alpha
    21 BuildRequires:  ghc, ghc-rpm-macros
    22 %if %{with doc}
    23 BuildRequires:  ghc-doc
    24 %endif
    25 %if %{with prof}
    26 BuildRequires:  ghc-prof
    27 %endif
     30BuildRequires:  ghc, ghc-doc, ghc-prof
     31BuildRequires:  ghc-rpm-macros >= 0.7.0
     32%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
     33%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
    2834
    2935%description
    30 This package provides the Haskell %{pkg_name} library for ghc.
    31 
    32 
    33 %package devel
    34 Summary:        Haskell %{pkg_name} library
    35 Group:          Development/Libraries
    36 Requires:       ghc = %{ghc_version}
    37 Requires(post): ghc = %{ghc_version}
    38 Requires(preun): ghc = %{ghc_version}
    39 
    40 %description devel
    41 This package contains the development files for %{name}
    42 built for ghc-%{ghc_version}.
    43 
    44 
    45 %if %{with doc}
    46 %package doc
    47 Summary:        Documentation for %{name}
    48 Group:          Development/Libraries
    49 Requires:       ghc-doc = %{ghc_version}
    50 Requires(post): ghc-doc = %{ghc_version}
    51 Requires(postun): ghc-doc = %{ghc_version}
    52 
    53 %description doc
    54 This package contains development documentation files for
    55 the %{name} library.
     36%{common_description}
     37%if %{with shared}
     38This package provides the shared library.
    5639%endif
    5740
    5841
    59 %if %{with prof}
    60 %package prof
    61 Summary:        Profiling libraries for %{name}
    62 Group:          Development/Libraries
    63 Requires:       %{name}-devel = %{version}-%{release}
    64 Requires:       ghc-prof = %{ghc_version}
    65 
    66 %description prof
    67 This package contains profiling libraries for %{name}
    68 built for ghc-%{ghc_version}.
    69 %endif
     42%{?ghc_lib_package}
    7043
    7144
     
    7548
    7649%build
    77 %cabal_configure --ghc %{?with_prof:-p}
    78 %cabal build
    79 %if %{with doc}
    80 %cabal haddock
    81 %endif
    82 %ghc_gen_scripts
     50%ghc_lib_build
    8351
    8452
    8553%install
    8654rm -rf $RPM_BUILD_ROOT
    87 %cabal_install
    88 %ghc_install_scripts
    89 %ghc_gen_filelists %{name}
     55%ghc_lib_install
    9056
    9157
     
    9460
    9561
    96 %post devel
    97 %ghc_register_pkg
    98 
    99 
    100 %if %{with doc}
    101 %post doc
    102 %ghc_reindex_haddock
    103 %endif
    104 
    105 
    106 %preun devel
    107 if [ "$1" -eq 0 ] ; then
    108   %ghc_unregister_pkg
    109 fi
    110 
    111 
    112 %if %{with doc}
    113 %postun doc
    114 if [ "$1" -eq 0 ] ; then
    115   %ghc_reindex_haddock
    116 fi
    117 %endif
    118 
    119 
    120 %files devel -f %{name}-devel.files
    121 %defattr(-,root,root,-)
    122 %{_docdir}/%{name}-%{version}
    123 
    124 
    125 %if %{with doc}
    126 %files doc -f %{name}-doc.files
    127 %defattr(-,root,root,-)
    128 %endif
    129 
    130 
    131 %if %{with prof}
    132 %files prof -f %{name}-prof.files
    133 %defattr(-,root,root,-)
    134 %endif
    135 
    136 
    13762%changelog
    138 * Mon Mar 15 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
    139 - initial packaging for Fedora automatically generated by cabal2spec
     63* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
     64- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracChangeset for help on using the changeset viewer.