Ignore:
Timestamp:
Apr 30, 2011, 11:56:37 AM (13 years ago)
Author:
achernya
Message:
Get ghc packages to build on F15

Regenerated the .spec files with cabal2spec for the Haskell packages
that are needed by Scripts, including bumping the versions to the
latest ones.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/fc15-dev/server/fedora/specs/ghc-unix-handle.spec

    r1693 r1826  
     1# For Haskell Packaging Guidelines see:
     2# - https://fedoraproject.org/wiki/Packaging:Haskell
     3# - https://fedoraproject.org/wiki/PackagingDrafts/Haskell
     4
    15%global pkg_name unix-handle
    26
     7# common part of summary for all the subpackages
    38%global common_summary Haskell %{pkg_name} library
    49
     10# main description used for all the subpackages
    511%global common_description A %{pkg_name} library for Haskell.
    612
    7 # add any Haskell library dependencies here:
     13# Haskell library dependencies (used for buildrequires and devel/prof subpkg requires)
    814#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
    915
    10 # add any foreign library dependencies here:
     16# foreign library dependencies (used for buildrequires and devel subpkg requires)
    1117#%%global ghc_pkg_c_deps @CDEP1@-devel
    12 
    13 %bcond_without shared
    14 
    15 # debuginfo is not useful for ghc
    16 %global debug_package %{nil}
    1718
    1819Name:           ghc-%{pkg_name}
     
    2223
    2324Group:          System Environment/Libraries
    24 License:        BSD
    25 URL:            http://hackage.haskell.org/cgi-bin/hackage-scripts/package/%{pkg_name}
     25License:        @LICENSE@
     26URL:            http://hackage.haskell.org/package/%{pkg_name}
    2627Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
    27 BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
    2828# fedora ghc archs:
    29 ExclusiveArch:  %{ix86} x86_64 ppc alpha
     29ExclusiveArch:  %{ix86} x86_64 ppc alpha sparcv9
    3030BuildRequires:  ghc, ghc-doc, ghc-prof
    31 BuildRequires:  ghc-rpm-macros >= 0.7.0
     31# macros for building haskell packages
     32BuildRequires:  ghc-rpm-macros >= 0.7.3
     33BuildRequires:  hscolour
    3234%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
    3335%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
     
    3537%description
    3638%{common_description}
    37 %if %{with shared}
    38 This package provides the shared library.
    39 %endif
    40 
    41 
    42 %{?ghc_lib_package}
    4339
    4440
     
    5248
    5349%install
    54 rm -rf $RPM_BUILD_ROOT
    5550%ghc_lib_install
    5651
    5752
    58 %clean
    59 rm -rf $RPM_BUILD_ROOT
     53# define the devel and prof subpkgs, devel post[un] scripts, and filelists:
     54# ghc-%pkg_name{,devel,prof}.files
     55%ghc_lib_package
    6056
    6157
    6258%changelog
     59* Sat Apr 30 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0
     60- regenerated packaging for Fedora automatically generated by cabal2spec-0.22.5
     61
    6362* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
    6463- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracChangeset for help on using the changeset viewer.