Ignore:
Timestamp:
Jun 27, 2012, 10:29:47 PM (10 years ago)
Author:
ezyang
Message:
Reintegrate Fedora 17 development branch into trunk.
Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk

  • trunk/server/fedora/specs/rubygems.spec.patch

    r2189 r2246  
    1 --- rubygems.spec.~1~   2012-04-20 14:46:27.000000000 -0400
    2 +++ rubygems.spec       2012-05-03 14:12:52.421863447 -0400
    3 @@ -15,7 +15,7 @@
     1--- rubygems.spec.~1~   2012-04-28 04:01:50.000000000 -0400
     2+++ rubygems.spec       2012-05-22 23:47:16.001145101 -0400
     3@@ -18,7 +18,7 @@
    44 Summary:       The Ruby standard for packaging ruby libraries
    55 Name:          rubygems
    6  Version:       1.7.2
    7 -Release:       5%{?dist}
    8 +Release:       5%{?dist}.scripts.%{scriptsversion}
     6 Version:       1.8.24
     7-Release:       1%{?dist}
     8+Release:       1%{?dist}.scripts.%{scriptsversion}
    99 Group:         Development/Libraries
    10  # No GPL version is specified.
    11  License:       Ruby or GPL+
    12 @@ -42,6 +42,9 @@
    13  # Insecure connection to SSL repository fix
    14  Patch10:       rubygems-1.x.x-ssl-connection-don_t-revert.patch
     10 License:       Ruby or MIT
     11 
     12@@ -52,6 +52,8 @@
     13 # https://github.com/rubygems/rubygems/issues/210
     14 Patch109:      rubygems-1.8.11-binary-extensions.patch
    1515 
    1616+Provides: scripts-rubygems = %{version}-%{release}
    1717+Patch1000: rubygems-rails-require-thread.patch
    18 +
    19  Requires:      ruby(abi) = 1.8
    20  Requires:      ruby >= 1.8.7
    21  Requires:      ruby-rdoc
    22 @@ -83,6 +86,8 @@
    23  %patch7 -p1 -b .esc.skip
    24  %patch10 -p1 -b .ssl
     18 
     19 Requires:      ruby(abi) = 1.9.1
     20 Requires:      rubygem(rdoc) >= 3.9.4
     21@@ -97,6 +99,8 @@
     22 %patch105 -p1 -b .uninst
     23 %patch109 -p1 -b .bindir
    2524 
    2625+%patch1000 -p1 -b .thread
Note: See TracChangeset for help on using the changeset viewer.