Changeset 1539


Ignore:
Timestamp:
Apr 16, 2010, 5:21:37 AM (12 years ago)
Author:
mitchb
Message:
Upgrade to Apache 2.2.15

Also drop the CVE-2010-0434 patch which is now incorporated upstream.
Location:
trunk/server
Files:
1 deleted
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/server/common/patches/httpd-2.2.x-mod_ssl-sessioncaching.patch

    r1348 r1539  
    1313         void *pV1, *pV2, *pV3, *pV4, *pV5, *pV6, *pV7, *pV8, *pV9, *pV10;
    1414     } rCtx;
    15 @@ -545,6 +548,7 @@ const char  *ssl_cmd_SSLRequire(cmd_parm
    16  const char  *ssl_cmd_SSLUserName(cmd_parms *, void *, const char *);
     15@@ -547,6 +550,7 @@ const char  *ssl_cmd_SSLRequire(cmd_parm
    1716 const char  *ssl_cmd_SSLRenegBufferSize(cmd_parms *cmd, void *dcfg, const char *arg);
    1817 const char  *ssl_cmd_SSLStrictSNIVHostCheck(cmd_parms *cmd, void *dcfg, int flag);
     18 const char *ssl_cmd_SSLInsecureRenegotiation(cmd_parms *cmd, void *dcfg, int flag);
    1919+const char  *ssl_cmd_SSLSessionTicketExtension(cmd_parms *cmd, void *cdfg, int flag);
    2020 
  • trunk/server/fedora/specs/httpd.spec.patch

    r1505 r1539  
    1 --- httpd.spec.orig     2010-02-28 05:01:55.000000000 -0500
    2 +++ httpd.spec  2010-03-11 05:30:54.000000000 -0500
     1--- httpd.spec.orig     2010-04-06 18:26:08.000000000 -0400
     2+++ httpd.spec  2010-04-14 04:14:13.000000000 -0400
    33@@ -7,7 +7,7 @@
    44 Summary: Apache HTTP Server
    55 Name: httpd
    6  Version: 2.2.14
    7 -Release: 1%{?dist}
    8 +Release: 1.scripts.%{scriptsversion}%{?dist}
     6 Version: 2.2.15
     7-Release: 1%{?dist}.1
     8+Release: 1%{?dist}.1.scripts.%{scriptsversion}
    99 URL: http://httpd.apache.org/
    1010 Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
    1111 Source1: index.html
    12 @@ -57,6 +57,14 @@
     12@@ -55,6 +55,13 @@
    1313 Conflicts: pcre < 4.0
    1414 Requires: httpd-tools = %{version}-%{release}, apr-util-ldap
     
    2020+Patch1005: httpd-2.2.x-mod_ssl-sessioncaching.patch
    2121+Patch1006: httpd-suexec-cloexec.patch
    22 +Patch1007: httpd-2.2.x-CVE-2010-0434.patch
    2322+
    2423 %description
    2524 The Apache HTTP Server is a powerful, efficient, and extensible
    2625 web server.
    27 @@ -104,6 +112,7 @@
     26@@ -102,6 +109,7 @@
    2827 Requires(post): openssl >= 0.9.7f-4, /bin/cat
    2928 Requires(pre): httpd
     
    3332 
    3433 %description -n mod_ssl
    35 @@ -133,6 +142,13 @@
     34@@ -129,6 +137,12 @@
    3635 # Patch in vendor/release string
    3736 sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
     
    4241+%patch1005 -p1 -b .ssl-sessioncache
    4342+%patch1006 -p1 -b .cloexec
    44 +%patch1007 -p1 -b .cve-2010-0434
    4543+
    4644 # Safety check: prevent build if defined MMN does not equal upstream MMN.
    4745 vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
    4846 if test "x${vmmn}" != "x%{mmn}"; then
    49 @@ -181,10 +197,12 @@
     47@@ -177,10 +191,12 @@
    5048         --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
    5149        --enable-suexec --with-suexec \
Note: See TracChangeset for help on using the changeset viewer.