1 | # Make sure to update these to coincide with the most recent debathena-moira |
---|
2 | # release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/ |
---|
3 | %define upstreamversion 4.0.0 |
---|
4 | %define snapshotversion cvs20091228 |
---|
5 | Summary: moira libraries, clients, and friends |
---|
6 | Group: Applications/System |
---|
7 | Name: moira |
---|
8 | Version: %{upstreamversion} |
---|
9 | Release: 2.%{scriptsversion}.%{snapshotversion} |
---|
10 | Vendor: The scripts.mit.edu Team (scripts@mit.edu) |
---|
11 | URL: http://scripts.mit.edu |
---|
12 | License: MIT |
---|
13 | Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz |
---|
14 | BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root |
---|
15 | #TODO: might really need mit-zephyr-devel, something for autotools-dev |
---|
16 | BuildRequires: readline-devel, e2fsprogs-devel, ncurses-devel, krb5-devel, hesiod-devel |
---|
17 | Patch0: moira-install-headers.patch |
---|
18 | Patch1: moira-update-server.rc.patch |
---|
19 | |
---|
20 | %description |
---|
21 | The moira library and clients. Clone of debathena-moira. |
---|
22 | See http://scripts.mit.edu/wiki for more information. |
---|
23 | |
---|
24 | %prep |
---|
25 | %setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion} |
---|
26 | %patch0 -p1 |
---|
27 | %patch1 |
---|
28 | |
---|
29 | %build |
---|
30 | # Hack: Add /usr/include/et to put com_err.h on the C include path. |
---|
31 | # Can remove this once the maintainer of the relevant package symlinks |
---|
32 | # com_err.h in /usr/include. |
---|
33 | # TODO: --with-zephyr is currently borked |
---|
34 | %configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et' |
---|
35 | make %{?_smp_mflags} |
---|
36 | |
---|
37 | %install |
---|
38 | rm -rf %{buildroot} |
---|
39 | make install DESTDIR=%{buildroot} |
---|
40 | mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira |
---|
41 | mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira |
---|
42 | mv %{buildroot}/%{_mandir}/man1/chsh.1 \ |
---|
43 | %{buildroot}/%{_mandir}/man1/chsh.moira.1 |
---|
44 | mv %{buildroot}/%{_mandir}/man1/chfn.1 \ |
---|
45 | %{buildroot}/%{_mandir}/man1/chfn.moira.1 |
---|
46 | install -m 755 -d %{buildroot}/%{_initddir} |
---|
47 | install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server |
---|
48 | # Hack: These man files are installed but no package uses them |
---|
49 | rm %{buildroot}/%{_mandir}/man8/dcm.8 |
---|
50 | rm %{buildroot}/%{_mandir}/man8/moirad.8 |
---|
51 | rm %{buildroot}/%{_mandir}/man8/reg_svr.8 |
---|
52 | rm %{buildroot}/%{_mandir}/man8/setquota.8 |
---|
53 | rm %{buildroot}/%{_mandir}/man8/startdcm.8 |
---|
54 | rm %{buildroot}/%{_mandir}/man8/startmoira.8 |
---|
55 | rm %{buildroot}/%{_mandir}/man8/startreg.8 |
---|
56 | |
---|
57 | %clean |
---|
58 | rm -rf %{buildroot} |
---|
59 | |
---|
60 | # clients |
---|
61 | %package clients |
---|
62 | Summary: Clients for the Moira database |
---|
63 | Group: Applications/System |
---|
64 | # Might need mit-zephyr-devel |
---|
65 | # Requires: mit-zephyr |
---|
66 | %description clients |
---|
67 | Moira is the Athena Service Management system. It serves as the |
---|
68 | central repository for information about users, groups hosts, print |
---|
69 | queues, and several other aspects of the Athena environment. |
---|
70 | |
---|
71 | This package contains clients such as moira, stella, blanche, etc. |
---|
72 | |
---|
73 | %files clients |
---|
74 | %defattr(755,root,root) |
---|
75 | %{_bindir}/addusr |
---|
76 | %{_bindir}/blanche |
---|
77 | %{_bindir}/chfn.moira |
---|
78 | %{_bindir}/chpobox |
---|
79 | %{_bindir}/chsh.moira |
---|
80 | %{_bindir}/eunice |
---|
81 | %{_bindir}/mitch |
---|
82 | %{_bindir}/namespace |
---|
83 | %{_bindir}/moira |
---|
84 | %{_bindir}/mrcheck |
---|
85 | %{_bindir}/mrtest |
---|
86 | %{_bindir}/stanley |
---|
87 | %{_bindir}/stella |
---|
88 | %{_bindir}/mailmaint |
---|
89 | %{_bindir}/listmaint |
---|
90 | %{_bindir}/dcmmaint |
---|
91 | %{_bindir}/usermaint |
---|
92 | %{_bindir}/update_test |
---|
93 | %defattr(-,root,root) |
---|
94 | %doc %{_mandir}/man1/* |
---|
95 | %doc %{_mandir}/man8/mrtest.8.gz |
---|
96 | |
---|
97 | |
---|
98 | # update-server |
---|
99 | %package update-server |
---|
100 | Summary: Athena update_server |
---|
101 | Group: Applications/System |
---|
102 | # Might need mit-zephyr-devel |
---|
103 | # Requires: mit-zephyr |
---|
104 | Requires(post): chkconfig |
---|
105 | Requires(preun): chkconfig |
---|
106 | %description update-server |
---|
107 | Moira is the Athena Service Management system. It serves as the |
---|
108 | central repository for information about users, groups hosts, print |
---|
109 | queues, and several other aspects of the Athena environment. |
---|
110 | |
---|
111 | This package contains the update_server daemon, which is used for |
---|
112 | servers that automatically receive information dumps from moira. |
---|
113 | |
---|
114 | %files update-server |
---|
115 | %defattr(-,root,root) |
---|
116 | %doc %{_mandir}/man8/update_server.8.gz |
---|
117 | %config(noreplace) %{_sysconfdir}/athena/moira.conf |
---|
118 | %defattr(755,root,root) |
---|
119 | %{_sbindir}/update_server |
---|
120 | %{_initddir}/moira-update-server |
---|
121 | |
---|
122 | %post update-server |
---|
123 | /sbin/chkconfig --add moira-update-server |
---|
124 | %{_initddir}/moira-update-server condrestart |
---|
125 | |
---|
126 | %preun update-server |
---|
127 | if [ $1 = 0 ] ; then |
---|
128 | /sbin/service moira-update-server stop >/dev/null 2>&1 |
---|
129 | /sbin/chkconfig --del moira-update-server |
---|
130 | fi |
---|
131 | |
---|
132 | # libmoira0 |
---|
133 | %package -n libmoira0 |
---|
134 | Summary: The Moira library |
---|
135 | Group: System Environment/Libraries |
---|
136 | %description -n libmoira0 |
---|
137 | Moira is the Athena Service Management system. It serves as the |
---|
138 | central repository for information about users, groups hosts, print |
---|
139 | queues, and several other aspects of the Athena environment. |
---|
140 | |
---|
141 | This package contains the shared Moira library. |
---|
142 | |
---|
143 | %post -n libmoira0 -p /sbin/ldconfig |
---|
144 | %postun -n libmoira0 -p /sbin/ldconfig |
---|
145 | |
---|
146 | %files -n libmoira0 |
---|
147 | %defattr(-,root,root) |
---|
148 | %{_libdir}/libmoira.so.* |
---|
149 | |
---|
150 | # libmoira-devel |
---|
151 | %package -n libmoira-devel |
---|
152 | Summary: Development files for Moira library |
---|
153 | Group: Development/Libraries |
---|
154 | # Might need mit-zephyr-devel |
---|
155 | # Requires: mit-zephyr |
---|
156 | Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel |
---|
157 | %description -n libmoira-devel |
---|
158 | Moira is the Athena Service Management system. It serves as the |
---|
159 | central repository for information about users, groups hosts, print |
---|
160 | queues, and several other aspects of the Athena environment. |
---|
161 | |
---|
162 | This package contains headers and static libraries for development. |
---|
163 | |
---|
164 | %post -n libmoira-devel -p /sbin/ldconfig |
---|
165 | %postun -n libmoira-devel -p /sbin/ldconfig |
---|
166 | |
---|
167 | %files -n libmoira-devel |
---|
168 | %defattr(-,root,root) |
---|
169 | %{_includedir}/* |
---|
170 | %doc %{_mandir}/man3/* |
---|
171 | %{_libdir}/libmoira.so |
---|
172 | %{_libdir}/libmoira.la |
---|
173 | %{_libdir}/libmoira.a |
---|
174 | |
---|
175 | %changelog |
---|
176 | * Mon Dec 28 2009 Mitchell Berger <mitchb@mit.edu> - 4.0.0-2.1402.cvs20091228 |
---|
177 | - Update to new upstream version, including eunice printer client |
---|
178 | |
---|
179 | * Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116 |
---|
180 | - Initial packaging of Moira on Fedora |
---|