source: trunk/server/fedora/specs/moira.spec @ 1402

Last change on this file since 1402 was 1402, checked in by gdb, 14 years ago
Removed mit-zephyr from the build deps
File size: 5.6 KB
Line 
1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
3%define upstreamversion 4.0.0
4%define snapshotversion cvs20091116
5Summary: moira libraries, clients, and friends
6Group: Applications/System
7Name: moira
8Version: %{upstreamversion}
9Release: 1.%{scriptsversion}.%{snapshotversion}
10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
12License: MIT
13Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz
14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
16BuildRequires: readline-devel, e2fsprogs-devel, ncurses-devel, krb5-devel, hesiod-devel
17Patch0: moira-install-headers.patch
18Patch1: moira-update-server.rc.patch
19
20%description
21The moira library and clients.  Clone of debathena-moira.
22See http://scripts.mit.edu/wiki for more information.
23
24%prep
25%setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion}
26%patch0 -p1
27%patch1
28
29%build
30# Hack: Add /usr/include/et to put com_err.h on the C include path.
31# Can remove this once the maintainer of the relevant package symlinks
32# com_err.h in /usr/include.
33# TODO: --with-zephyr is currently borked
34%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
35make %{?_smp_mflags}
36
37%install
38rm -rf %{buildroot}
39make install DESTDIR=%{buildroot}
40mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
41mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
42mv %{buildroot}/%{_mandir}/man1/chsh.1 \
43   %{buildroot}/%{_mandir}/man1/chsh.moira.1
44mv %{buildroot}/%{_mandir}/man1/chfn.1 \
45   %{buildroot}/%{_mandir}/man1/chfn.moira.1
46install -m 755 -d %{buildroot}/%{_initddir}
47install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
48# Hack: These man files are installed but no package uses them
49rm %{buildroot}/%{_mandir}/man8/dcm.8
50rm %{buildroot}/%{_mandir}/man8/moirad.8
51rm %{buildroot}/%{_mandir}/man8/reg_svr.8
52rm %{buildroot}/%{_mandir}/man8/setquota.8
53rm %{buildroot}/%{_mandir}/man8/startdcm.8
54rm %{buildroot}/%{_mandir}/man8/startmoira.8
55rm %{buildroot}/%{_mandir}/man8/startreg.8
56
57%clean
58rm -rf %{buildroot}
59
60# clients
61%package clients
62Summary: Clients for the Moira database
63Group: Applications/System
64# Might need mit-zephyr-devel
65# Requires: mit-zephyr
66%description clients
67Moira is the Athena Service Management system.  It serves as the
68central repository for information about users, groups hosts, print
69queues, and several other aspects of the Athena environment.
70
71This package contains clients such as moira, stella, blanche, etc.
72
73%files clients
74%defattr(755,root,root)
75%{_bindir}/addusr
76%{_bindir}/blanche
77%{_bindir}/chfn.moira
78%{_bindir}/chpobox
79%{_bindir}/chsh.moira
80%{_bindir}/mitch
81%{_bindir}/namespace
82%{_bindir}/moira
83%{_bindir}/mrcheck
84%{_bindir}/mrtest
85%{_bindir}/stanley
86%{_bindir}/stella
87%{_bindir}/mailmaint
88%{_bindir}/listmaint
89%{_bindir}/dcmmaint
90%{_bindir}/usermaint
91%{_bindir}/update_test
92%defattr(-,root,root)
93%doc %{_mandir}/man1/*
94%doc %{_mandir}/man8/mrtest.8.gz
95
96
97# update-server
98%package update-server
99Summary: Athena update_server
100Group: Applications/System
101# Might need mit-zephyr-devel
102# Requires: mit-zephyr
103Requires(post): chkconfig
104Requires(preun): chkconfig
105%description update-server
106Moira is the Athena Service Management system.  It serves as the
107central repository for information about users, groups hosts, print
108queues, and several other aspects of the Athena environment.
109
110This package contains the update_server daemon, which is used for
111servers that automatically receive information dumps from moira.
112
113%files update-server
114%defattr(-,root,root)
115%doc %{_mandir}/man8/update_server.8.gz
116%config(noreplace) %{_sysconfdir}/athena/moira.conf
117%defattr(755,root,root)
118%{_sbindir}/update_server
119%{_initddir}/moira-update-server
120
121%post update-server
122/sbin/chkconfig --add moira-update-server
123%{_initddir}/moira-update-server condrestart
124
125%preun update-server
126if [ $1 = 0 ] ; then
127    /sbin/service moira-update-server stop >/dev/null 2>&1
128    /sbin/chkconfig --del moira-update-server
129fi
130
131# libmoira0
132%package -n libmoira0
133Summary: The Moira library
134Group: System Environment/Libraries
135%description -n libmoira0
136Moira is the Athena Service Management system.  It serves as the
137central repository for information about users, groups hosts, print
138queues, and several other aspects of the Athena environment.
139
140This package contains the shared Moira library.
141
142%post -n libmoira0 -p /sbin/ldconfig
143%postun -n libmoira0 -p /sbin/ldconfig
144
145%files -n libmoira0
146%defattr(-,root,root)
147%{_libdir}/libmoira.so.*
148
149# libmoira-devel
150%package -n libmoira-devel
151Summary: Development files for Moira library
152Group: Development/Libraries
153# Might need mit-zephyr-devel
154# Requires: mit-zephyr
155Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel
156%description -n libmoira-devel
157Moira is the Athena Service Management system.  It serves as the
158central repository for information about users, groups hosts, print
159queues, and several other aspects of the Athena environment.
160
161This package contains headers and static libraries for development.
162
163%post -n libmoira-devel -p /sbin/ldconfig
164%postun -n libmoira-devel -p /sbin/ldconfig
165
166%files -n libmoira-devel
167%defattr(-,root,root)
168%{_includedir}/*
169%doc %{_mandir}/man3/*
170%{_libdir}/libmoira.so
171%{_libdir}/libmoira.la
172%{_libdir}/libmoira.a
173
174%changelog
175* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
176- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.