source: trunk/server/fedora/specs/moira.spec @ 1460

Last change on this file since 1460 was 1406, checked in by mitchb, 14 years ago
Play Evan on TV (update moira to new snapshot, provide shared libmrclient)
File size: 7.4 KB
RevLine 
[1396]1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
[1397]3%define upstreamversion 4.0.0
[1406]4%define snapshotversion svn20100104
[1399]5Summary: moira libraries, clients, and friends
[1394]6Group: Applications/System
7Name: moira
[1397]8Version: %{upstreamversion}
[1406]9Release: 3.%{scriptsversion}.%{snapshotversion}
[1394]10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
[1396]12License: MIT
[1397]13Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz
[1394]14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
[1402]16BuildRequires: readline-devel, e2fsprogs-devel, ncurses-devel, krb5-devel, hesiod-devel
[1396]17Patch0: moira-install-headers.patch
18Patch1: moira-update-server.rc.patch
[1406]19Patch2: moira-fix-manpage-paths.patch
[1394]20
21%description
[1399]22The moira library and clients.  Clone of debathena-moira.
[1394]23See http://scripts.mit.edu/wiki for more information.
24
25%prep
[1397]26%setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion}
[1394]27%patch0 -p1
[1396]28%patch1
[1406]29%patch2 -p1
[1394]30
31%build
32# Hack: Add /usr/include/et to put com_err.h on the C include path.
33# Can remove this once the maintainer of the relevant package symlinks
34# com_err.h in /usr/include.
[1406]35# (See https://bugzilla.redhat.com/show_bug.cgi?id=550889)
[1394]36# TODO: --with-zephyr is currently borked
37%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
38make %{?_smp_mflags}
39
40%install
41rm -rf %{buildroot}
42make install DESTDIR=%{buildroot}
43mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
44mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
45mv %{buildroot}/%{_mandir}/man1/chsh.1 \
46   %{buildroot}/%{_mandir}/man1/chsh.moira.1
47mv %{buildroot}/%{_mandir}/man1/chfn.1 \
48   %{buildroot}/%{_mandir}/man1/chfn.moira.1
49install -m 755 -d %{buildroot}/%{_initddir}
[1396]50install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
[1394]51# Hack: These man files are installed but no package uses them
52rm %{buildroot}/%{_mandir}/man8/dcm.8
53rm %{buildroot}/%{_mandir}/man8/moirad.8
54rm %{buildroot}/%{_mandir}/man8/reg_svr.8
55rm %{buildroot}/%{_mandir}/man8/setquota.8
56rm %{buildroot}/%{_mandir}/man8/startdcm.8
57rm %{buildroot}/%{_mandir}/man8/startmoira.8
58rm %{buildroot}/%{_mandir}/man8/startreg.8
59
60%clean
61rm -rf %{buildroot}
62
[1396]63# clients
64%package clients
[1394]65Summary: Clients for the Moira database
66Group: Applications/System
[1397]67# Might need mit-zephyr-devel
68# Requires: mit-zephyr
[1396]69%description clients
[1394]70Moira is the Athena Service Management system.  It serves as the
71central repository for information about users, groups hosts, print
72queues, and several other aspects of the Athena environment.
73
74This package contains clients such as moira, stella, blanche, etc.
75
[1396]76%files clients
77%defattr(755,root,root)
[1394]78%{_bindir}/addusr
79%{_bindir}/blanche
80%{_bindir}/chfn.moira
81%{_bindir}/chpobox
82%{_bindir}/chsh.moira
[1403]83%{_bindir}/eunice
[1394]84%{_bindir}/mitch
85%{_bindir}/namespace
86%{_bindir}/moira
87%{_bindir}/mrcheck
88%{_bindir}/mrtest
89%{_bindir}/stanley
90%{_bindir}/stella
91%{_bindir}/mailmaint
92%{_bindir}/listmaint
93%{_bindir}/dcmmaint
94%{_bindir}/usermaint
95%{_bindir}/update_test
[1396]96%defattr(-,root,root)
[1394]97%doc %{_mandir}/man1/*
98%doc %{_mandir}/man8/mrtest.8.gz
99
100
[1396]101# update-server
102%package update-server
[1394]103Summary: Athena update_server
104Group: Applications/System
[1397]105# Might need mit-zephyr-devel
106# Requires: mit-zephyr
[1394]107Requires(post): chkconfig
108Requires(preun): chkconfig
[1396]109%description update-server
[1394]110Moira is the Athena Service Management system.  It serves as the
111central repository for information about users, groups hosts, print
112queues, and several other aspects of the Athena environment.
113
114This package contains the update_server daemon, which is used for
115servers that automatically receive information dumps from moira.
116
[1396]117%files update-server
[1394]118%defattr(-,root,root)
119%doc %{_mandir}/man8/update_server.8.gz
[1406]120%config(noreplace) %{_sysconfdir}/moira.conf
[1394]121%defattr(755,root,root)
122%{_sbindir}/update_server
123%{_initddir}/moira-update-server
124
[1396]125%post update-server
[1394]126/sbin/chkconfig --add moira-update-server
[1396]127%{_initddir}/moira-update-server condrestart
[1394]128
[1396]129%preun update-server
[1394]130if [ $1 = 0 ] ; then
131    /sbin/service moira-update-server stop >/dev/null 2>&1
132    /sbin/chkconfig --del moira-update-server
133fi
134
135# libmoira0
[1396]136%package -n libmoira0
[1394]137Summary: The Moira library
138Group: System Environment/Libraries
[1396]139%description -n libmoira0
[1394]140Moira is the Athena Service Management system.  It serves as the
141central repository for information about users, groups hosts, print
142queues, and several other aspects of the Athena environment.
143
144This package contains the shared Moira library.
145
[1396]146%post -n libmoira0 -p /sbin/ldconfig
147%postun -n libmoira0 -p /sbin/ldconfig
148
149%files -n libmoira0
150%defattr(-,root,root)
[1394]151%{_libdir}/libmoira.so.*
152
[1396]153# libmoira-devel
154%package -n libmoira-devel
[1394]155Summary: Development files for Moira library
156Group: Development/Libraries
[1397]157# Might need mit-zephyr-devel
158# Requires: mit-zephyr
159Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel
[1396]160%description -n libmoira-devel
[1394]161Moira is the Athena Service Management system.  It serves as the
162central repository for information about users, groups hosts, print
163queues, and several other aspects of the Athena environment.
164
165This package contains headers and static libraries for development.
166
[1396]167%post -n libmoira-devel -p /sbin/ldconfig
168%postun -n libmoira-devel -p /sbin/ldconfig
169
170%files -n libmoira-devel
[1394]171%defattr(-,root,root)
[1406]172%{_includedir}/moira
173%exclude %{_includedir}/moira/mrclient.h
[1394]174%doc %{_mandir}/man3/*
175%{_libdir}/libmoira.so
176%{_libdir}/libmoira.la
177%{_libdir}/libmoira.a
[1396]178
[1406]179# libmrclient0
180%package -n libmrclient0
181Summary: The Moira client library
182Group: System Environment/Libraries
183%description -n libmrclient0
184Moira is the Athena Service Management system.  It serves as the
185central repository for information about users, groups hosts, print
186queues, and several other aspects of the Athena environment.
187
188This package contains the shared Moira client library.
189
190%post -n libmrclient0 -p /sbin/ldconfig
191%postun -n libmrclient0 -p /sbin/ldconfig
192
193%files -n libmrclient0
194%defattr(-,root,root)
195%{_libdir}/libmrclient.so.*
196
197# libmrclient-devel
198%package -n libmrclient-devel
199Summary: Development files for Moira client library
200Group: Development/Libraries
201Requires: libmrclient0 = %{version}-%{release}, libmoira-devel = %{version}-%{release}
202%description -n libmrclient-devel
203Moira is the Athena Service Management system.  It serves as the
204central repository for information about users, groups hosts, print
205queues, and several other aspects of the Athena environment.
206
207This package contains headers and static libraries for development.
208
209%post -n libmrclient-devel -p /sbin/ldconfig
210%postun -n libmrclient-devel -p /sbin/ldconfig
211
212%files -n libmrclient-devel
213%defattr(-,root,root)
214%{_includedir}/moira/mrclient.h
215%{_libdir}/libmrclient.so
216%{_libdir}/libmrclient.la
217%{_libdir}/libmrclient.a
218
[1396]219%changelog
[1406]220* Tue Jan 05 2010 Mitchell Berger <mitchb@mit.edu> - 4.0.0-3.1405M.svn20100104
221- Update to new original upstream version (svn snapshot)
222- Build and install libmrclient as a shared library (from Debathena)
223
[1403]224* Mon Dec 28 2009 Mitchell Berger <mitchb@mit.edu> - 4.0.0-2.1402.cvs20091228
225- Update to new upstream version, including eunice printer client
226
[1396]227* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
228- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.