source: trunk/server/fedora/specs/moira.spec @ 1396

Last change on this file since 1396 was 1396, checked in by gdb, 14 years ago
Built and mildly tested moira RPM
File size: 5.6 KB
RevLine 
[1396]1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
3%define debversion 4.0.0
4%define upstreamversion cvs20091116
5Summary: rpm packaging of moira libraries, clients, and friends.
[1394]6Group: Applications/System
7Name: moira
[1396]8Version: %{debversion}
9Release: 2.%{scriptsversion}.%{upstreamversion}
[1394]10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
[1396]12License: MIT
13Source: debathena-%{name}_%{debversion}+%{upstreamversion}.orig.tar.gz
[1394]14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
[1396]16BuildRequires: readline-devel, e2fsprogs-devel, mit-zephyr, ncurses-devel, krb5-devel, hesiod-devel
17Patch0: moira-install-headers.patch
18Patch1: moira-update-server.rc.patch
[1394]19
20%description
[1396]21rpm packaging of moira libraries, clients, and friends.
[1394]22
23Source package for the moira library and clients.  Clone of debathena-moira.
24See http://scripts.mit.edu/wiki for more information.
25
26%prep
[1396]27%setup -q -n debathena-%{name}-%{debversion}+%{upstreamversion}
[1394]28%patch0 -p1
[1396]29%patch1
[1394]30
31%build
32# Hack: Add /usr/include/et to put com_err.h on the C include path.
33# Can remove this once the maintainer of the relevant package symlinks
34# com_err.h in /usr/include.
35# TODO: --with-zephyr is currently borked
36%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
37make %{?_smp_mflags}
38
39%install
40rm -rf %{buildroot}
41make install DESTDIR=%{buildroot}
42mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
43mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
44mv %{buildroot}/%{_mandir}/man1/chsh.1 \
45   %{buildroot}/%{_mandir}/man1/chsh.moira.1
46mv %{buildroot}/%{_mandir}/man1/chfn.1 \
47   %{buildroot}/%{_mandir}/man1/chfn.moira.1
48install -m 755 -d %{buildroot}/%{_initddir}
[1396]49install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
[1394]50# Hack: These man files are installed but no package uses them
51rm %{buildroot}/%{_mandir}/man8/dcm.8
52rm %{buildroot}/%{_mandir}/man8/moirad.8
53rm %{buildroot}/%{_mandir}/man8/reg_svr.8
54rm %{buildroot}/%{_mandir}/man8/setquota.8
55rm %{buildroot}/%{_mandir}/man8/startdcm.8
56rm %{buildroot}/%{_mandir}/man8/startmoira.8
57rm %{buildroot}/%{_mandir}/man8/startreg.8
58
59%clean
60rm -rf %{buildroot}
61
[1396]62# clients
63%package clients
[1394]64Summary: Clients for the Moira database
65Group: Applications/System
[1396]66%description clients
[1394]67Clients for the Moira database
68
69Moira is the Athena Service Management system.  It serves as the
70central repository for information about users, groups hosts, print
71queues, and several other aspects of the Athena environment.
72
73This package contains clients such as moira, stella, blanche, etc.
74
[1396]75%files clients
76%defattr(755,root,root)
[1394]77%{_bindir}/addusr
78%{_bindir}/blanche
79%{_bindir}/chfn.moira
80%{_bindir}/chpobox
81%{_bindir}/chsh.moira
82%{_bindir}/mitch
83%{_bindir}/namespace
84%{_bindir}/moira
85%{_bindir}/mrcheck
86%{_bindir}/mrtest
87%{_bindir}/stanley
88%{_bindir}/stella
89%{_bindir}/mailmaint
90%{_bindir}/listmaint
91%{_bindir}/dcmmaint
92%{_bindir}/usermaint
93%{_bindir}/update_test
[1396]94%defattr(-,root,root)
[1394]95%doc %{_mandir}/man1/*
96%doc %{_mandir}/man8/mrtest.8.gz
97
98
[1396]99# update-server
100%package update-server
[1394]101Summary: Athena update_server
102Group: Applications/System
103Requires(post): chkconfig
104Requires(preun): chkconfig
[1396]105%description update-server
[1394]106Athena update_server
107
108Moira is the Athena Service Management system.  It serves as the
109central repository for information about users, groups hosts, print
110queues, and several other aspects of the Athena environment.
111
112This package contains the update_server daemon, which is used for
113servers that automatically receive information dumps from moira.
114
[1396]115%files update-server
[1394]116%defattr(-,root,root)
117%doc %{_mandir}/man8/update_server.8.gz
118%config(noreplace) %{_sysconfdir}/athena/moira.conf
119%defattr(755,root,root)
120%{_sbindir}/update_server
121%{_initddir}/moira-update-server
122
[1396]123%post update-server
[1394]124/sbin/chkconfig --add moira-update-server
[1396]125%{_initddir}/moira-update-server condrestart
[1394]126
[1396]127%preun update-server
[1394]128if [ $1 = 0 ] ; then
129    /sbin/service moira-update-server stop >/dev/null 2>&1
130    /sbin/chkconfig --del moira-update-server
131fi
132
133# libmoira0
[1396]134%package -n libmoira0
[1394]135Summary: The Moira library
136Group: System Environment/Libraries
[1396]137%description -n libmoira0
[1394]138The Moira library
139
140Moira is the Athena Service Management system.  It serves as the
141central repository for information about users, groups hosts, print
142queues, and several other aspects of the Athena environment.
143
144This package contains the shared Moira library.
145
[1396]146%post -n libmoira0 -p /sbin/ldconfig
147%postun -n libmoira0 -p /sbin/ldconfig
148
149%files -n libmoira0
150%defattr(-,root,root)
[1394]151%{_libdir}/libmoira.so.*
152
[1396]153# libmoira-devel
154%package -n libmoira-devel
[1394]155Summary: Development files for Moira library
156Group: Development/Libraries
[1396]157Provides: libmoira-devel
[1394]158Requires: libmoira0
[1396]159%description -n libmoira-devel
[1394]160Development files for Moira library
161
162Moira is the Athena Service Management system.  It serves as the
163central repository for information about users, groups hosts, print
164queues, and several other aspects of the Athena environment.
165
166This package contains headers and static libraries for development.
167
[1396]168%post -n libmoira-devel -p /sbin/ldconfig
169%postun -n libmoira-devel -p /sbin/ldconfig
170
171%files -n libmoira-devel
[1394]172%defattr(-,root,root)
173%{_includedir}/*
174%doc %{_mandir}/man3/*
175%{_libdir}/libmoira.so
176%{_libdir}/libmoira.la
177%{_libdir}/libmoira.a
[1396]178
179%changelog
180* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
181- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.