source: trunk/server/fedora/specs/moira.spec @ 1397

Last change on this file since 1397 was 1397, checked in by gdb, 14 years ago
Fixed Requires for libmoira-devel, small style fixes in moira.spec
File size: 5.8 KB
Line 
1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
3%define upstreamversion 4.0.0
4%define snapshotversion cvs20091116
5Summary: rpm of moira libraries, clients, and friends
6Group: Applications/System
7Name: moira
8Version: %{upstreamversion}
9Release: 1.%{scriptsversion}.%{snapshotversion}
10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
12License: MIT
13Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz
14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
16BuildRequires: readline-devel, e2fsprogs-devel, mit-zephyr, ncurses-devel, krb5-devel, hesiod-devel
17Patch0: moira-install-headers.patch
18Patch1: moira-update-server.rc.patch
19
20%description
21rpm of moira libraries, clients, and friends
22
23Source package for the moira library and clients.  Clone of debathena-moira.
24See http://scripts.mit.edu/wiki for more information.
25
26%prep
27%setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion}
28%patch0 -p1
29%patch1
30
31%build
32# Hack: Add /usr/include/et to put com_err.h on the C include path.
33# Can remove this once the maintainer of the relevant package symlinks
34# com_err.h in /usr/include.
35# TODO: --with-zephyr is currently borked
36%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
37make %{?_smp_mflags}
38
39%install
40rm -rf %{buildroot}
41make install DESTDIR=%{buildroot}
42mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
43mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
44mv %{buildroot}/%{_mandir}/man1/chsh.1 \
45   %{buildroot}/%{_mandir}/man1/chsh.moira.1
46mv %{buildroot}/%{_mandir}/man1/chfn.1 \
47   %{buildroot}/%{_mandir}/man1/chfn.moira.1
48install -m 755 -d %{buildroot}/%{_initddir}
49install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
50# Hack: These man files are installed but no package uses them
51rm %{buildroot}/%{_mandir}/man8/dcm.8
52rm %{buildroot}/%{_mandir}/man8/moirad.8
53rm %{buildroot}/%{_mandir}/man8/reg_svr.8
54rm %{buildroot}/%{_mandir}/man8/setquota.8
55rm %{buildroot}/%{_mandir}/man8/startdcm.8
56rm %{buildroot}/%{_mandir}/man8/startmoira.8
57rm %{buildroot}/%{_mandir}/man8/startreg.8
58
59%clean
60rm -rf %{buildroot}
61
62# clients
63%package clients
64Summary: Clients for the Moira database
65Group: Applications/System
66# Might need mit-zephyr-devel
67# Requires: mit-zephyr
68%description clients
69Clients for the Moira database
70
71Moira is the Athena Service Management system.  It serves as the
72central repository for information about users, groups hosts, print
73queues, and several other aspects of the Athena environment.
74
75This package contains clients such as moira, stella, blanche, etc.
76
77%files clients
78%defattr(755,root,root)
79%{_bindir}/addusr
80%{_bindir}/blanche
81%{_bindir}/chfn.moira
82%{_bindir}/chpobox
83%{_bindir}/chsh.moira
84%{_bindir}/mitch
85%{_bindir}/namespace
86%{_bindir}/moira
87%{_bindir}/mrcheck
88%{_bindir}/mrtest
89%{_bindir}/stanley
90%{_bindir}/stella
91%{_bindir}/mailmaint
92%{_bindir}/listmaint
93%{_bindir}/dcmmaint
94%{_bindir}/usermaint
95%{_bindir}/update_test
96%defattr(-,root,root)
97%doc %{_mandir}/man1/*
98%doc %{_mandir}/man8/mrtest.8.gz
99
100
101# update-server
102%package update-server
103Summary: Athena update_server
104Group: Applications/System
105# Might need mit-zephyr-devel
106# Requires: mit-zephyr
107Requires(post): chkconfig
108Requires(preun): chkconfig
109%description update-server
110Athena update_server
111
112Moira is the Athena Service Management system.  It serves as the
113central repository for information about users, groups hosts, print
114queues, and several other aspects of the Athena environment.
115
116This package contains the update_server daemon, which is used for
117servers that automatically receive information dumps from moira.
118
119%files update-server
120%defattr(-,root,root)
121%doc %{_mandir}/man8/update_server.8.gz
122%config(noreplace) %{_sysconfdir}/athena/moira.conf
123%defattr(755,root,root)
124%{_sbindir}/update_server
125%{_initddir}/moira-update-server
126
127%post update-server
128/sbin/chkconfig --add moira-update-server
129%{_initddir}/moira-update-server condrestart
130
131%preun update-server
132if [ $1 = 0 ] ; then
133    /sbin/service moira-update-server stop >/dev/null 2>&1
134    /sbin/chkconfig --del moira-update-server
135fi
136
137# libmoira0
138%package -n libmoira0
139Summary: The Moira library
140Group: System Environment/Libraries
141%description -n libmoira0
142The Moira library
143
144Moira is the Athena Service Management system.  It serves as the
145central repository for information about users, groups hosts, print
146queues, and several other aspects of the Athena environment.
147
148This package contains the shared Moira library.
149
150%post -n libmoira0 -p /sbin/ldconfig
151%postun -n libmoira0 -p /sbin/ldconfig
152
153%files -n libmoira0
154%defattr(-,root,root)
155%{_libdir}/libmoira.so.*
156
157# libmoira-devel
158%package -n libmoira-devel
159Summary: Development files for Moira library
160Group: Development/Libraries
161# Might need mit-zephyr-devel
162# Requires: mit-zephyr
163Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel
164%description -n libmoira-devel
165Development files for Moira library
166
167Moira is the Athena Service Management system.  It serves as the
168central repository for information about users, groups hosts, print
169queues, and several other aspects of the Athena environment.
170
171This package contains headers and static libraries for development.
172
173%post -n libmoira-devel -p /sbin/ldconfig
174%postun -n libmoira-devel -p /sbin/ldconfig
175
176%files -n libmoira-devel
177%defattr(-,root,root)
178%{_includedir}/*
179%doc %{_mandir}/man3/*
180%{_libdir}/libmoira.so
181%{_libdir}/libmoira.la
182%{_libdir}/libmoira.a
183
184%changelog
185* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
186- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.