source: trunk/server/fedora/specs/ghc-unix-handle.spec @ 2066

Last change on this file since 2066 was 2066, checked in by achernya, 12 years ago
Merge branches/fc15-dev to trunk
File size: 1.9 KB
Line 
1# For Haskell Packaging Guidelines see:
2# - https://fedoraproject.org/wiki/Packaging:Haskell
3# - https://fedoraproject.org/wiki/PackagingDrafts/Haskell
4
5%global pkg_name unix-handle
6
7# common part of summary for all the subpackages
8%global common_summary Haskell %{pkg_name} library
9
10# main description used for all the subpackages
11%global common_description A %{pkg_name} library for Haskell.
12
13# Haskell library dependencies (used for buildrequires and devel/prof subpkg requires)
14#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
15
16# foreign library dependencies (used for buildrequires and devel subpkg requires)
17#%%global ghc_pkg_c_deps @CDEP1@-devel
18
19Name:           ghc-%{pkg_name}
20Version:        0.0.0
21Release:        0.%{scriptsversion}%{?dist}
22Summary:        %{common_summary}
23
24Group:          System Environment/Libraries
25License:        BSD
26URL:            http://hackage.haskell.org/package/%{pkg_name}
27Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
28# fedora ghc archs:
29ExclusiveArch:  %{ix86} x86_64 ppc alpha sparcv9
30BuildRequires:  ghc, ghc-doc, ghc-prof
31# macros for building haskell packages
32BuildRequires:  ghc-rpm-macros >= 0.7.3
33BuildRequires:  hscolour
34%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
35%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
36
37%description
38%{common_description}
39
40
41%prep
42%setup -q -n %{pkg_name}-%{version}
43
44
45%build
46%ghc_lib_build
47
48
49%install
50%ghc_lib_install
51
52
53# define the devel and prof subpkgs, devel post[un] scripts, and filelists:
54# ghc-%pkg_name{,devel,prof}.files
55%ghc_lib_package
56
57
58%changelog
59* Mon May  2 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0
60- regenerated packaging with cabal2spec-0.22.5
61
62* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
63- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.