source: trunk/server/fedora/specs/ghc-unix-handle.spec

Last change on this file was 2591, checked in by achernya, 10 years ago
Reintegrate fc20-dev into trunk
File size: 2.0 KB
Line 
1# https://fedoraproject.org/wiki/Packaging:Haskell
2
3%global pkg_name unix-handle
4
5Name:           ghc-%{pkg_name}
6Version:        0.0.0
7Release:        0.%{scriptsversion}%{?dist}
8Summary:        POSIX operations on Handles
9
10License:        BSD
11URL:            http://hackage.haskell.org/package/%{pkg_name}
12Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
13
14BuildRequires:  ghc-Cabal-devel
15BuildRequires:  ghc-rpm-macros %{!?without_hscolour:hscolour}
16# Begin cabal-rpm deps:
17BuildRequires:  ghc-unix-devel
18# End cabal-rpm deps
19
20%description
21This package provides versions of functions from "System.Posix.Files" that
22operate on 'System.IO.Handle' instead of 'System.IO.FilePath' or
23'System.Posix.Fd'. This is useful to prevent race conditions that may arise
24from looking up the same path twice.
25
26
27%package devel
28Summary:        Haskell %{pkg_name} library development files
29Provides:       %{name}-static = %{version}-%{release}
30Requires:       ghc-compiler = %{ghc_version}
31Requires(post): ghc-compiler = %{ghc_version}
32Requires(postun): ghc-compiler = %{ghc_version}
33Requires:       %{name}%{?_isa} = %{version}-%{release}
34
35%description devel
36This package provides the Haskell %{pkg_name} library development files.
37
38
39%prep
40%setup -q -n %{pkg_name}-%{version}
41
42
43%build
44%ghc_lib_build
45
46
47%install
48%ghc_lib_install
49
50
51%post devel
52%ghc_pkg_recache
53
54
55%postun devel
56%ghc_pkg_recache
57
58
59%files -f %{name}.files
60%doc LICENSE
61
62
63%files devel -f %{name}-devel.files
64
65
66%changelog
67* Mon May 26 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.0.0-0
68- Updated packaging for F20 with cabal-rpm
69
70* Fri May 25 2012 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
71- regenerated packaging with cabal2spec-0.25.5
72
73* Mon May  2 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0
74- regenerated packaging with cabal2spec-0.22.5
75
76* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
77- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.