1 | # Generated from pony-1.8.gem by gem2rpm -*- rpm-spec -*- |
---|
2 | %global gem_name pony |
---|
3 | |
---|
4 | Name: rubygem-%{gem_name} |
---|
5 | Version: 1.8 |
---|
6 | Release: 2%{?dist}.scripts.%{scriptsversion} |
---|
7 | Summary: Send email in one command: Pony.mail(:to => 'someone@example.com', :body => 'hello') |
---|
8 | Group: Development/Languages |
---|
9 | License: MIT |
---|
10 | URL: http://github.com/benprew/pony |
---|
11 | Source0: http://rubygems.org/gems/%{gem_name}-%{version}.gem |
---|
12 | Requires: ruby(release) |
---|
13 | Requires: ruby(rubygems) |
---|
14 | Requires: rubygem(mail) >= 2.0 |
---|
15 | BuildRequires: ruby(release) |
---|
16 | BuildRequires: rubygems-devel |
---|
17 | BuildRequires: ruby |
---|
18 | BuildArch: noarch |
---|
19 | Provides: rubygem(%{gem_name}) = %{version} |
---|
20 | |
---|
21 | %description |
---|
22 | Send email in one command: Pony.mail(:to => 'someone@example.com', :body => |
---|
23 | 'hello') |
---|
24 | |
---|
25 | |
---|
26 | %package doc |
---|
27 | Summary: Documentation for %{name} |
---|
28 | Group: Documentation |
---|
29 | Requires: %{name} = %{version}-%{release} |
---|
30 | BuildArch: noarch |
---|
31 | |
---|
32 | %description doc |
---|
33 | Documentation for %{name} |
---|
34 | |
---|
35 | %prep |
---|
36 | gem unpack %{SOURCE0} |
---|
37 | |
---|
38 | %setup -q -D -T -n %{gem_name}-%{version} |
---|
39 | |
---|
40 | gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec |
---|
41 | |
---|
42 | %build |
---|
43 | mkdir -p .%{gem_dir} |
---|
44 | |
---|
45 | # Create the gem as gem install only works on a gem file |
---|
46 | gem build %{gem_name}.gemspec |
---|
47 | |
---|
48 | |
---|
49 | # gem install installs into a directory. We set that to be a local |
---|
50 | # directory so that we can move it into the buildroot in %%install |
---|
51 | gem install --local --install-dir ./%{gem_dir} \ |
---|
52 | --force --rdoc %{gem_name}-%{version}.gem |
---|
53 | |
---|
54 | %install |
---|
55 | mkdir -p %{buildroot}%{gem_dir} |
---|
56 | cp -pa .%{gem_dir}/* \ |
---|
57 | %{buildroot}%{gem_dir}/ |
---|
58 | rm -f %{buildroot}%{gem_instdir}/{Rakefile,pony.gemspec} |
---|
59 | rm -rf %{buildroot}%{gem_instdir}/spec |
---|
60 | |
---|
61 | |
---|
62 | %files |
---|
63 | %dir %{gem_instdir} |
---|
64 | %{gem_libdir} |
---|
65 | %exclude %{gem_cache} |
---|
66 | %{gem_spec} |
---|
67 | |
---|
68 | %files doc |
---|
69 | %doc %{gem_docdir} |
---|
70 | %doc %{gem_instdir}/README.rdoc |
---|
71 | |
---|
72 | %changelog |
---|
73 | * Mon May 26 2014 Alexander Chernyakhovsky <achernya@mit.edu> - 1.8-2 |
---|
74 | - Update for Fedora 20 |
---|
75 | |
---|
76 | * Sun Mar 09 2014 Benjamin Tidor <btidor@mit.edu> - 1.8-1 |
---|
77 | - Initial package |
---|