source: branches/fc20-dev/server/fedora/specs/rubygem-pony.spec @ 2523

Last change on this file since 2523 was 2522, checked in by achernya, 10 years ago
Merge r2487-r2521 from trunk to branches/fc19-dev
File size: 1.8 KB
Line 
1# Generated from pony-1.8.gem by gem2rpm -*- rpm-spec -*-
2%global gem_name pony
3%global rubyabi 1.9.1
4
5Name: rubygem-%{gem_name}
6Version: 1.8
7Release: 1%{?dist}.scripts.%{scriptsversion}
8Summary: Send email in one command: Pony.mail(:to => 'someone@example.com', :body => 'hello')
9Group: Development/Languages
10License: MIT
11URL: http://github.com/benprew/pony
12Source0: http://rubygems.org/gems/%{gem_name}-%{version}.gem
13Requires: ruby(abi) = %{rubyabi}
14Requires: ruby(rubygems)
15Requires: rubygem(mail) >= 2.0
16BuildRequires: ruby(abi) = %{rubyabi}
17BuildRequires: rubygems-devel
18BuildRequires: ruby
19BuildArch: noarch
20Provides: rubygem(%{gem_name}) = %{version}
21
22%description
23Send email in one command: Pony.mail(:to => 'someone@example.com', :body =>
24'hello')
25
26
27%package doc
28Summary: Documentation for %{name}
29Group: Documentation
30Requires: %{name} = %{version}-%{release}
31BuildArch: noarch
32
33%description doc
34Documentation for %{name}
35
36%prep
37gem unpack %{SOURCE0}
38
39%setup -q -D -T -n  %{gem_name}-%{version}
40
41gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
42
43%build
44mkdir -p .%{gem_dir}
45
46# Create the gem as gem install only works on a gem file
47gem build %{gem_name}.gemspec
48
49
50# gem install installs into a directory.  We set that to be a local
51# directory so that we can move it into the buildroot in %%install
52gem install --local --install-dir ./%{gem_dir} \
53            --force --rdoc %{gem_name}-%{version}.gem
54
55%install
56mkdir -p %{buildroot}%{gem_dir}
57cp -pa .%{gem_dir}/* \
58        %{buildroot}%{gem_dir}/
59rm -f %{buildroot}%{gem_instdir}/{Rakefile,pony.gemspec}
60rm -rf %{buildroot}%{gem_instdir}/spec
61
62
63%files
64%dir %{gem_instdir}
65%{gem_libdir}
66%exclude %{gem_cache}
67%{gem_spec}
68
69%files doc
70%doc %{gem_docdir}
71%doc %{gem_instdir}/README.rdoc
72
73%changelog
74* Sun Mar 09 2014 Benjamin Tidor <btidor@mit.edu> - 1.8-1
75- Initial package
Note: See TracBrowser for help on using the repository browser.