[2587] | 1 | # sitelib for noarch packages, sitearch for others (remove the unneeded one) |
---|
| 2 | %{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")} |
---|
| 3 | %{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")} |
---|
| 4 | |
---|
| 5 | Name: python-authkit |
---|
| 6 | Version: 0.4.5 |
---|
[2588] | 7 | Release: 2%{?dist} |
---|
[2587] | 8 | Summary: An authentication and authorization toolkit for WSGI applications and frameworks |
---|
| 9 | |
---|
| 10 | License: MIT |
---|
| 11 | URL: https://pypi.python.org/pypi/AuthKit/0.4.5 |
---|
| 12 | Source0: https://pypi.python.org/packages/source/A/AuthKit/AuthKit-0.4.5.tar.gz |
---|
| 13 | |
---|
| 14 | BuildArch: noarch |
---|
| 15 | |
---|
| 16 | BuildRequires: python-setuptools |
---|
| 17 | BuildRequires: python2-devel |
---|
| 18 | |
---|
[2588] | 19 | Requires: python-beaker |
---|
| 20 | Requires: python-decorator |
---|
| 21 | Requires: python-nose |
---|
| 22 | Requires: python-openid |
---|
| 23 | Requires: python-paste |
---|
| 24 | Requires: python-paste-deploy |
---|
| 25 | Requires: python-paste-script |
---|
| 26 | Requires: python-webob |
---|
| 27 | |
---|
| 28 | Patch0: python-authkit.patch |
---|
| 29 | |
---|
[2587] | 30 | %description |
---|
| 31 | * Built for WSGI applications and middleware |
---|
| 32 | * Sophisticated and extensible permissions system |
---|
| 33 | * Built in support for HTTP basic, HTTP digest, form, cookie and |
---|
| 34 | OpenID authentication methods plus others |
---|
| 35 | * Easily define users, passwords and roles |
---|
| 36 | * Designed to be totally extensible so you can use the components to |
---|
| 37 | integrate with a database, LDAP connection or your own custom system |
---|
| 38 | * Plays nicely with the Pylons web framework |
---|
| 39 | |
---|
| 40 | |
---|
| 41 | %prep |
---|
| 42 | %setup -q -n AuthKit-%{version} |
---|
[2588] | 43 | %patch0 -p1 |
---|
[2587] | 44 | |
---|
| 45 | |
---|
| 46 | %build |
---|
| 47 | # Remove CFLAGS=... for noarch packages (unneeded) |
---|
| 48 | CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build |
---|
| 49 | |
---|
| 50 | |
---|
| 51 | %install |
---|
| 52 | rm -rf $RPM_BUILD_ROOT |
---|
| 53 | %{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT |
---|
| 54 | |
---|
| 55 | |
---|
| 56 | %files |
---|
| 57 | %doc |
---|
| 58 | # For noarch packages: sitelib |
---|
| 59 | %{python_sitelib}/* |
---|
| 60 | |
---|
| 61 | |
---|
| 62 | %changelog |
---|
[2588] | 63 | * Thu Aug 28 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.4.5-2 |
---|
| 64 | - Correct ElementTree import. |
---|
| 65 | |
---|
[2587] | 66 | * Thu Aug 28 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.4.5-1 |
---|
| 67 | - Initial packaging. |
---|