source: branches/fc20-dev/server/fedora/specs/python-authkit.spec @ 2587

Last change on this file since 2587 was 2587, checked in by achernya, 10 years ago
Add an authkit-shaped rpmegg
File size: 1.6 KB
Line 
1# sitelib for noarch packages, sitearch for others (remove the unneeded one)
2%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
4
5Name:           python-authkit
6Version:        0.4.5
7Release:        1%{?dist}
8Summary:        An authentication and authorization toolkit for WSGI applications and frameworks
9
10License:        MIT
11URL:            https://pypi.python.org/pypi/AuthKit/0.4.5
12Source0:        https://pypi.python.org/packages/source/A/AuthKit/AuthKit-0.4.5.tar.gz
13
14BuildArch:      noarch
15
16BuildRequires:  python-setuptools
17BuildRequires:  python2-devel
18
19%description
20* Built for WSGI applications and middleware
21* Sophisticated and extensible permissions system
22* Built in support for HTTP basic, HTTP digest, form, cookie and
23  OpenID authentication methods plus others
24* Easily define users, passwords and roles
25* Designed to be totally extensible so you can use the components to
26  integrate with a database, LDAP connection or your own custom system
27* Plays nicely with the Pylons web framework
28
29
30%prep
31%setup -q -n AuthKit-%{version}
32
33
34%build
35# Remove CFLAGS=... for noarch packages (unneeded)
36CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
42
43 
44%files
45%doc
46# For noarch packages: sitelib
47%{python_sitelib}/*
48
49
50%changelog
51* Thu Aug 28 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.4.5-1
52- Initial packaging.
Note: See TracBrowser for help on using the repository browser.