Changeset 2198 for branches/fc17-dev


Ignore:
Timestamp:
May 23, 2012, 12:48:29 AM (10 years ago)
Author:
ezyang
Message:
Untested version bumps for all spec files.
Location:
branches/fc17-dev/server/fedora/specs
Files:
6 edited

Legend:

Unmodified
Added
Removed
  • branches/fc17-dev/server/fedora/specs/httpd.spec.patch

    r2195 r2198  
    1 --- httpd.spec.~1~      2012-02-13 09:46:36.000000000 -0500
    2 +++ httpd.spec  2012-03-26 01:33:53.247271289 -0400
    3 @@ -8,7 +8,7 @@
     1--- httpd.spec.~1~      2012-04-30 05:52:31.000000000 -0400
     2+++ httpd.spec  2012-05-22 23:31:12.397142763 -0400
     3@@ -9,7 +9,7 @@
    44 Summary: Apache HTTP Server
    55 Name: httpd
    66 Version: 2.2.22
    7 -Release: 1%{?dist}
    8 +Release: 1%{?dist}.scripts.%{scriptsversion}
     7-Release: 4%{?dist}
     8+Release: 4%{?dist}.scripts.%{scriptsversion}
    99 URL: http://httpd.apache.org/
    1010 Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
    1111 Source1: index.html
    12 @@ -54,6 +54,15 @@
    13  Provides: httpd-mmn = %{mmn}, httpd-mmn = %{mmnisa}
    14  Requires: httpd-tools = %{version}-%{release}, apr-util-ldap, systemd-units
     12@@ -58,6 +58,15 @@
     13 Requires(postun): systemd-units
     14 Requires(post): systemd-units
    1515 
    1616+Provides: scripts-httpd = %{version}-%{release}
     
    2626 The Apache HTTP Server is a powerful, efficient, and extensible
    2727 web server.
    28 @@ -64,6 +76,7 @@
     28@@ -68,6 +77,7 @@
    2929 Obsoletes: secureweb-devel, apache-devel, stronghold-apache-devel
    3030 Requires: apr-devel, apr-util-devel, pkgconfig
     
    3434 %description devel
    3535 The httpd-devel package contains the APXS binary and other files
    36 @@ -102,6 +115,7 @@
     36@@ -106,6 +116,7 @@
    3737 Requires(post): openssl, /bin/cat
    3838 Requires(pre): httpd
     
    4242 
    4343 %description -n mod_ssl
    44 @@ -110,6 +124,11 @@
     44@@ -114,6 +125,11 @@
    4545 Security (TLS) protocols.
    4646 
     
    5454 %patch1 -p1 -b .apctl
    5555 %patch2 -p1 -b .apxs
    56 @@ -128,6 +147,14 @@
     56@@ -133,6 +149,14 @@
    5757 # Patch in vendor/release string
    5858 sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
     
    6969 vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
    7070 if test "x${vmmn}" != "x%{mmn}"; then
    71 @@ -175,10 +205,12 @@
     71@@ -193,10 +217,12 @@
    7272         --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
    7373        --enable-suexec --with-suexec \
  • branches/fc17-dev/server/fedora/specs/krb5.spec.patch

    r2195 r2198  
    1 --- krb5.spec.~1~       2012-03-08 16:20:41.000000000 -0500
    2 +++ krb5.spec   2012-04-01 22:07:14.834013302 -0400
    3 @@ -6,7 +6,7 @@
     1--- krb5.spec.~1~       2012-03-08 16:26:28.000000000 -0500
     2+++ krb5.spec   2012-05-22 23:34:03.312147899 -0400
     3@@ -15,7 +15,7 @@
    44 Summary: The Kerberos network authentication system
    55 Name: krb5
    6  Version: 1.9.3
    7 -Release: 1%{?dist}
    8 +Release: 1%{?dist}.scripts.%{scriptsversion}
     6 Version: 1.10
     7-Release: 5%{?dist}
     8+Release: 5%{?dist}.scripts.%{scriptsversion}
    99 # Maybe we should explode from the now-available-to-everybody tarball instead?
    10  # http://web.mit.edu/kerberos/dist/krb5/1.9/krb5-1.9.3-signed.tar
     10 # http://web.mit.edu/kerberos/dist/krb5/1.10/krb5-1.10-signed.tar
    1111 Source0: krb5-%{version}.tar.gz
    12 @@ -64,6 +64,8 @@
    13  Patch102: krb5-1.9-7048.patch
    14  Patch103: krb5-kvno-230379.patch
     12@@ -66,6 +66,8 @@
     13 Patch106: krb5-1.10-lookaside.patch
     14 Patch107: krb5-1.10-string-rpc-acl-fix.patch
    1515 
    1616+Patch1000: krb5-kuserok-scripts.patch
     
    1919 URL: http://web.mit.edu/kerberos/www/
    2020 Group: System Environment/Libraries
    21 @@ -113,6 +115,7 @@
     21@@ -119,6 +121,7 @@
    2222 %package libs
    2323 Summary: The shared libraries used by Kerberos 5
     
    2727 %description libs
    2828 Kerberos is a network authentication system. The krb5-libs package
    29 @@ -219,6 +222,7 @@
    30  %patch101 -p1 -b .7047
    31  %patch102 -p1 -b .7048
    32  %patch103 -p1 -b .kvno
     29@@ -238,6 +241,7 @@
     30 %patch105 -p1 -b .kvno
     31 %patch106 -p1 -b .7082
     32 %patch107 -p1 -b .7093
    3333+%patch1000 -p1 -b .kuserok
     34 rm src/lib/krb5/krb/deltat.c
     35 
    3436 gzip doc/*.ps
    35  
    36  sed -i -e '1s!\[twoside\]!!;s!%\(\\usepackage{hyperref}\)!\1!' doc/api/library.tex
  • branches/fc17-dev/server/fedora/specs/openssh.spec.patch

    r2195 r2198  
    1 --- openssh.spec.~1~    2012-02-14 11:06:13.000000000 -0500
    2 +++ openssh.spec        2012-02-25 13:02:28.660616538 -0500
    3 @@ -78,7 +78,7 @@
     1--- openssh.spec.~1~    2012-04-06 15:22:23.000000000 -0400
     2+++ openssh.spec        2012-05-22 23:36:52.700142966 -0400
     3@@ -82,7 +82,7 @@
    44 Summary: An open source implementation of SSH protocol versions 1 and 2
    55 Name: openssh
     
    1010 #URL1: http://pamsshagentauth.sourceforge.net
    1111 #Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
    12 @@ -92,6 +92,7 @@
    13  Source3: sshd.init
    14  Source4: http://prdownloads.sourceforge.net/pamsshagentauth/pam_ssh_agent_auth/pam_ssh_agent_auth-%{pam_ssh_agent_ver}.tar.bz2
    15  Source5: pam_ssh_agent-rmheaders
     12@@ -218,6 +218,7 @@
     13 #https://bugzilla.mindrot.org/show_bug.cgi?id=1604
     14 # sctp
     15 #https://bugzilla.mindrot.org/show_bug.cgi?id=1873 => https://bugzilla.redhat.com/show_bug.cgi?id=668993
    1616+Patch1001: openssh-4.7p1-gssapi-name-in-env.patch
    1717 
    18  Patch100: openssh-5.6p1-wIm.patch
    19  Patch0: openssh-5.6p1-redhat.patch
    20 @@ -214,6 +215,7 @@
    21  Requires(pre): /usr/sbin/useradd
    22  Requires: pam >= 1.0.1-3
     18 License: BSD
     19 Group: Applications/Internet
     20@@ -271,6 +272,7 @@
     21 Group: Applications/Internet
     22 Requires: openssh = %{version}-%{release}
    2323 Requires: fipscheck-lib%{_isa} >= 1.3.0
    2424+Provides: scripts-openssh-server
    2525 
    26  %if %{ldap}
    27  %package ldap
    28 @@ -333,6 +335,8 @@
    29  %patch83 -p0 -b .oomkiller
    30  %patch84 -p1 -b .legacy
     26 %package server
     27 Summary: An open source SSH server daemon
     28@@ -465,6 +467,8 @@
     29 # Nothing here yet
     30 %endif
    3131 
    3232+%patch1001 -p1 -b .gssapi-env
  • branches/fc17-dev/server/fedora/specs/php.spec.patch

    r2195 r2198  
    1 --- php.spec.~1~        2012-02-02 17:13:59.000000000 -0500
    2 +++ php.spec    2012-05-03 14:18:22.234721036 -0400
    3 @@ -37,7 +37,7 @@
     1--- php.spec.~1~        2012-04-27 13:42:25.000000000 -0400
     2+++ php.spec    2012-05-22 23:38:56.360148746 -0400
     3@@ -56,7 +56,7 @@
    44 Summary: PHP scripting language for creating dynamic web sites
    55 Name: php
    6  Version: 5.3.10
     6 Version: 5.4.1
    77-Release: 1%{?dist}
    88+Release: 1%{?dist}.scripts.%{scriptsversion}
     
    1010 Group: Development/Languages
    1111 URL: http://www.php.net/
    12 @@ -76,6 +76,9 @@
     12@@ -91,6 +91,9 @@
    1313 # Fixes for tests
    14  Patch61: php-5.0.4-tests-wddx.patch
     14 
    1515 
    1616+Provides: scripts-php
     
    1919 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
    2020 
    21  BuildRequires: bzip2-devel, curl-devel >= 7.9, db4-devel, gmp-devel
    22 @@ -544,6 +547,8 @@
    23  
    24  %patch61 -p1 -b .tests-wddx
     21 BuildRequires: bzip2-devel, curl-devel >= 7.9, %{db_devel}, gmp-devel
     22@@ -584,6 +587,8 @@
     23 %patch44 -p1 -b .systzip
     24 %endif
    2525 
    2626+%patch100 -p0 -b .cve-2012-1823
  • branches/fc17-dev/server/fedora/specs/redland-bindings.spec.patch

    r2066 r2198  
    1 --- redland-bindings.spec.old   2011-10-12 14:51:58.000000000 -0400
    2 +++ redland-bindings.spec       2011-10-13 10:15:24.000000000 -0400
     1--- redland-bindings.spec.~1~   2012-03-06 07:34:14.000000000 -0500
     2+++ redland-bindings.spec       2012-05-22 23:43:49.839142648 -0400
    33@@ -1,6 +1,6 @@
    44 Name:           redland-bindings
    5  Version:        1.0.11.1
    6 -Release:        6%{?dist}
    7 +Release:        6%{?dist}.scripts.%{scriptsversion}
     5 Version:        1.0.14.1
     6-Release:        1%{?dist}
     7+Release:        1%{?dist}.scripts.%{scriptsversion}
    88 Summary:        Redland RDF Application Framework API Bindings
    99 
    1010 Group:          System Environment/Libraries
    11 @@ -137,6 +137,9 @@
    12  autoconf
    13  automake
     11@@ -130,6 +130,8 @@
     12 #autoconf
     13 #automake
    1414 
    1515+# Horrible hack to make PHP work
    1616+sed -i -e 's/zend_error_noreturn/zend_error/' php/*
    17 +
    18  # when specifying system redland, the configure check for the version
    19  # allows newer redland libraries; without it it doesn't.
    20  # authors says that older bindings work with newer redlands.
     17 
     18 %build
     19 %configure \
  • branches/fc17-dev/server/fedora/specs/rubygems.spec.patch

    r2195 r2198  
    1 --- rubygems.spec.~1~   2012-04-20 14:46:27.000000000 -0400
    2 +++ rubygems.spec       2012-05-03 14:12:52.421863447 -0400
    3 @@ -15,7 +15,7 @@
     1--- rubygems.spec.~1~   2012-04-28 04:01:50.000000000 -0400
     2+++ rubygems.spec       2012-05-22 23:47:16.001145101 -0400
     3@@ -18,7 +18,7 @@
    44 Summary:       The Ruby standard for packaging ruby libraries
    55 Name:          rubygems
    6  Version:       1.7.2
    7 -Release:       5%{?dist}
    8 +Release:       5%{?dist}.scripts.%{scriptsversion}
     6 Version:       1.8.24
     7-Release:       1%{?dist}
     8+Release:       1%{?dist}.scripts.%{scriptsversion}
    99 Group:         Development/Libraries
    10  # No GPL version is specified.
    11  License:       Ruby or GPL+
    12 @@ -42,6 +42,9 @@
    13  # Insecure connection to SSL repository fix
    14  Patch10:       rubygems-1.x.x-ssl-connection-don_t-revert.patch
     10 License:       Ruby or MIT
     11 
     12@@ -52,6 +52,8 @@
     13 # https://github.com/rubygems/rubygems/issues/210
     14 Patch109:      rubygems-1.8.11-binary-extensions.patch
    1515 
    1616+Provides: scripts-rubygems = %{version}-%{release}
    1717+Patch1000: rubygems-rails-require-thread.patch
    18 +
    19  Requires:      ruby(abi) = 1.8
    20  Requires:      ruby >= 1.8.7
    21  Requires:      ruby-rdoc
    22 @@ -83,6 +86,8 @@
    23  %patch7 -p1 -b .esc.skip
    24  %patch10 -p1 -b .ssl
     18 
     19 Requires:      ruby(abi) = 1.9.1
     20 Requires:      rubygem(rdoc) >= 3.9.4
     21@@ -97,6 +99,8 @@
     22 %patch105 -p1 -b .uninst
     23 %patch109 -p1 -b .bindir
    2524 
    2625+%patch1000 -p1 -b .thread
Note: See TracChangeset for help on using the changeset viewer.