Ignore:
Timestamp:
Nov 9, 2011, 1:45:19 PM (11 years ago)
Author:
ezyang
Message:
Nuke install-deps from orbit; Mock handles these.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/fc15-dev/server/fedora/Makefile

    r2026 r2040  
    181181        fi
    182182
    183 # The following packages are needed for our packages
    184 basic-deps      = kernel-devel rpm-build rpmdevtools mock gcc autoconf patch krb5-workstation glibc-devel.i686 glibc-devel libtool libgcc.i686
    185 oursrc-deps     = hesinfo openldap-clients openldap-devel.i686 php-devel
    186 httpdmods-deps  = httpd-devel
    187 httpd-deps      = xmlto db4-devel expat-devel zlib-devel libselinux-devel apr-devel apr-util-devel pcre-devel openssl-devel distcache-devel
    188 krb5-deps       = bison ncurses-devel texinfo keyutils-libs-devel texinfo-tex texlive-latex libss-devel rsh
    189 openafs-deps    = pam-devel automake
    190 moira-deps      = e2fsprogs-devel
    191 zephyr-deps     = hesiod-devel libss-devel krb5-devel readline-devel
    192 openssh-deps    = gtk2-devel libX11-devel autoconf automake openssl-devel perl zlib-devel audit-libs-devel util-linux groff man pam-devel tcp_wrappers-devel krb5-devel libselinux-devel audit-libs xauth pango-devel cairo-devel libedit-devel nss-devel fipscheck-devel
    193 php-deps        = bzip2-devel curl-devel gmp-devel libstdc++-devel sqlite-devel gcc-c++ libc-client-devel mysql-devel postgresql-devel unixODBC-devel libxml2-devel net-snmp-devel libxslt-devel libxml2-devel libXpm-devel libjpeg-devel t1lib-devel libmcrypt-devel mhash-devel libtidy-devel freetds-devel aspell-devel recode-devel
    194 haskell-deps    = cabal-install
    195 # ezyang: not 100% sure this is correct
    196 rubygems-deps   = ruby ruby-rdoc
    197 install-deps:
    198         yum -y install $(basic-deps) $(oursrc-deps) $(httpdmods-deps) $(httpd-deps) $(krb5-deps) $(openafs-deps) $(moira-deps) $(zephyr-deps) $(openssh-deps) $(php-deps) $(haskell-deps) $(rubygems-deps)
    199183# XXX: We need to figure out what's going on with compat-readline43
    200184#       rpm -ivh http://kojipkgs.fedoraproject.org/packages/compat-readline43/4.3/3/i386/compat-readline43-4.3-3.i386.rpm
     
    202186
    203187fedora:
    204         make install-deps
    205188        make upstream
    206189        rpm -ivh $(out_rpms)/`uname -m`/openafs-devel*.rpm
Note: See TracChangeset for help on using the changeset viewer.