Changeset 1952


Ignore:
Timestamp:
Aug 21, 2011, 4:27:12 PM (10 years ago)
Author:
achernya
Message:
Make httpd.spec.patch have versioned Provides

httpdmods uses a versioned Requires on scripts-httpd, but
scripts-httpd was previously unversioned. RPM and friends treat this
as "provides any version" (as opposed to version 0), satisfying the
Requires without actually doing any useful checks.
File:
1 edited

Legend:

Unmodified
Added
Removed
  • branches/fc15-dev/server/fedora/specs/httpd.spec.patch

    r1949 r1952  
    1414 Requires: httpd-tools = %{version}-%{release}, apr-util-ldap, systemd-units
    1515 
    16 +Provides: scripts-httpd
     16+Provides: scripts-httpd = %{version}-%{release}
    1717+Patch1000: httpd-suexec-scripts.patch
    1818+Patch1003: httpd-2.2.x-mod_status-security.patch
     
    2929 Requires: apr-devel, apr-util-devel, pkgconfig
    3030 Requires: httpd = %{version}-%{release}
    31 +Provides: scripts-httpd-devel
     31+Provides: scripts-httpd-devel = %{version}-%{release}
    3232 
    3333 %description devel
Note: See TracChangeset for help on using the changeset viewer.