Changeset 1334 for trunk/server/fedora


Ignore:
Timestamp:
Oct 4, 2009, 2:47:36 AM (13 years ago)
Author:
mitchb
Message:
Change the Scripts build system to build under mock!
Location:
trunk/server/fedora
Files:
3 added
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/server/fedora/Makefile

    r1329 r1334  
    1919# See /COPYRIGHT in this repository for more information.
    2020
    21 upstream_yum    = krb5 httpd openssh php rubygem-activesupport-2.3.2-1.fc11 rubygem-actionpack-2.3.2-1.fc11
     21upstream_yum    = krb5 krb5.i586 httpd openssh php rubygem-activesupport-2.3.2-1.fc11 rubygem-actionpack-2.3.2-1.fc11
    2222upstream        = openafs $(upstream_yum)
    2323oursrc          = execsys tokensys accountadm httpdmods logview sql-signup nss_nonlocal nss_nonlocal.i586 whoisd mit-zephyr athrun php_scripts scripts-base
     
    3939server_arch     = "fedora.stable"
    4040openafs_url     = "http://dl.openafs.org/dl/openafs/1.4.11/openafs-1.4.11-1.1.1.src.rpm"
     41
     42PKG             = $(patsubst %.i586,%,$@)
    4143
    4244.PHONY: minimal-clean
     
    127129$(filter %.i586,$(oursrc)): %.i586: setup
    128130        PATH="/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin" \
    129         setarch i586 rpmbuild $(rpmbuild_args) --target=i586 --define="_lib lib" -bb ${tmp_specs}/$**.spec
     131        rpmbuild ${rpmbuild_args} -bs ${tmp_specs}/${PKG}.spec
     132        /usr/bin/mock -r scripts-fc11-i386 --arch=i586 ${rpmbuild_args} --define="_lib lib" -v --rebuild `ls -t ${out_srpms}/${PKG}-[0-9]*.src.rpm | head -1`
    130133
    131134$(filter-out %.i586,$(oursrc)): %: setup
    132135        PATH="/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin" \
    133         rpmbuild $(rpmbuild_args) -bb ${tmp_specs}/$**.spec
     136        rpmbuild ${rpmbuild_args} -bs ${tmp_specs}/${PKG}.spec
     137        /usr/bin/mock -r scripts-fc11-`uname -m` ${rpmbuild_args} -v --rebuild `ls -t ${out_srpms}/${PKG}-[0-9]*.src.rpm | head -1`
    134138
    135139$(upstream) rubygem-activesupport rubygem-actionpack openafs-kernel: rpmbuild_args += --define 'scriptsversion $(shell svnversion ${patches} | tr ':' '_')'
    136140
    137 $(upstream) rubygem-activesupport rubygem-actionpack: setup patch-specs
    138         rpmbuild $(rpmbuild_args) -ba ${tmp_specs}/$@.spec
     141$(filter %.i586,$(upstream)): %.i586: setup patch-specs
     142        rpmbuild ${rpmbuild_args} -bs ${tmp_specs}/${PKG}.spec
     143        /usr/bin/mock -r scripts-fc11-i386 --arch=i586 ${rpmbuild_args} -v --rebuild `ls -t ${out_srpms}/${PKG}-[0-9]*.src.rpm | head -1`
     144
     145$(filter-out %.i586,$(upstream)) rubygem-activesupport rubygem-actionpack: %: setup patch-specs
     146        rpmbuild ${rpmbuild_args} -bs ${tmp_specs}/${PKG}.spec
     147        /usr/bin/mock -r scripts-fc11-`uname -m` ${rpmbuild_args} -v --rebuild `ls -t ${out_srpms}/${PKG}-[0-9]*.src.rpm | head -1`
    139148
    140149openafs-kernel: setup
    141150        PATH="/usr/kerberos/sbin:/usr/kerberos/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin" \
    142         rpmbuild $(rpmbuild_args) -bb ${tmp_specs}/openafs*.spec
     151        rpmbuild ${rpmbuild_args} -bs ${tmp_specs}/openafs*.spec
     152        /usr/bin/mock -r scripts-fc11-`uname -m` ${rpmbuild_args} -v --rebuild `ls -t ${out_srpms}/openafs*.src.rpm | head -1`
    143153
    144154#sort -n sorts "2.6.25-1" later than "2.6.25.1-1", so it's Wrong
     
    146156kernvers = $(shell uname -r | sed "s/\(.*\)[.].*/\1/")
    147157kvariants = ''
    148 openafs_rpmbuild_args = --define "fedorakmod 1" --define "kvariants $(kvariants)" --define "kernvers $(kernvers)" --nodeps
     158openafs_rpmbuild_args = --define "fedorakmod 1" --define "kvariants $(kvariants)" --define "kernvers $(kernvers)"
    149159openafs: rpmbuild_args += $(openafs_rpmbuild_args)
    150160openafs-kernel: rpmbuild_args += $(openafs_rpmbuild_args) --define "build_userspace 0" --define "build_modules 1"
     
    177187
    178188# The following packages are needed for our packages
    179 basic-deps      = kernel-devel rpm-build rpmdevtools gcc autoconf patch krb5-workstation glibc-devel.i586 glibc-devel libtool libgcc.i586
     189basic-deps      = kernel-devel rpm-build rpmdevtools mock gcc autoconf patch krb5-workstation glibc-devel.i586 glibc-devel libtool libgcc.i586
    180190oursrc-deps     = hesinfo openldap-clients openldap-devel.i586 php-devel
    181191httpdmods-deps  = httpd-devel
Note: See TracChangeset for help on using the changeset viewer.