source: trunk/server/fedora/specs/gnutls.spec.patch @ 2533

Last change on this file since 2533 was 2507, checked in by achernya, 9 years ago
Fix gnutls CVE 2014-0092
File size: 989 bytes
  • gnutls.spec

    old new  
    11Summary: A TLS protocol implementation
    22Name: gnutls
    33Version: 2.12.23
    4 Release: 2%{?dist}
     4Release: 2%{?dist}.scripts.%{scriptsversion}
    55# The libgnutls library is LGPLv2+, utilities and remaining libraries are GPLv3+
    66License: GPLv3+ and LGPLv2+
    77Group: System Environment/Libraries
     
    2626# Use only FIPS approved ciphers in the FIPS mode
    2727Patch7: gnutls-2.12.21-fips-algorithms.patch
    2828Patch8: gnutls-2.12.23-cve-2013-2116.patch
     29# Patch GNUTLS-SA-2014-2
     30Patch9: gnutls-2.12.x-cve-2014-0092.patch
    2931
    3032BuildRoot:  %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
    3133Requires: libgcrypt >= 1.2.2
     
    99101%patch6 -p1 -b .cli-debug
    100102%patch7 -p1 -b .fips
    101103%patch8 -p1 -b .overread
     104%patch9 -p1 -b .cve-2014-0092
    102105
    103106for i in auth_srp_rsa.c auth_srp_sb64.c auth_srp_passwd.c auth_srp.c gnutls_srp.c ext_srp.c; do
    104107    touch lib/$i
Note: See TracBrowser for help on using the repository browser.