source: server/fedora/specs/execsys.spec @ 922

Last change on this file since 922 was 922, checked in by quentin, 15 years ago
don't stop execsys on package updates
File size: 1.7 KB
Line 
1Summary: scripts.mit.edu glue associated with file execution
2Group: Applications/System
3Name: execsys
4Version: 0.SVNVERSION_TO_UPDATE
5Release: 0
6Vendor: The scripts.mit.edu Team (scripts@mit.edu)
7URL: http://scripts.mit.edu
8License: GPL
9Requires: xinetd
10Source: %{name}.tar.gz
11BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
12%define debug_package %{nil}
13
14%description
15
16scripts.mit.edu glue associated with file execution
17Contains:
18 - Apache configuration file <execsys.conf>
19 - binfmt_misc init script <execsys-binfmt>
20 - Binary for serving static content <static-cat>
21See http://scripts.mit.edu/wiki for more information.
22
23%prep
24%setup -q -n %{name}
25
26%build
27./configure --prefix=/usr/local --with-pl=/usr/bin/perl --with-php=/usr/bin/php-cgi --with-py=/usr/bin/python --with-exe=/usr/bin/mono
28make SYSCATDIR=/usr/local/sbin
29
30%install
31[ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
32make install DESTDIR=$RPM_BUILD_ROOT SYSCATDIR=/usr/local/sbin
33
34%clean
35[ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
36
37%files
38%defattr(0644, root, root)
39/etc/httpd/conf.d/execsys.conf
40%defattr(0755, root, root)
41/usr/local/bin/static-cat
42/etc/init.d/execsys-binfmt
43/usr/local/sbin/ldapize.pl
44/usr/local/sbin/svnproxy.pl
45/usr/libexec/scripts-trusted/svn
46/etc/xinetd.d/scripts-svn
47/usr/local/sbin/gitproxy.pl
48/usr/libexec/scripts-trusted/git
49/etc/xinetd.d/scripts-git
50
51%post
52chkconfig --add execsys-binfmt
53service execsys-binfmt start
54service xinetd reload
55
56%preun
57if [ "$1" = "0" ] ; then
58   service execsys-binfmt stop
59   chkconfig --del execsys-binfmt
60fi
61
62%postun
63service xinetd reload
64
65%changelog
66* Wed Dec 31 2008  Quentin Smith <quentin@mit.edu>
67- don't stop execsys on package updates
68
69* Sat Sep 30 2006  Jeff Arnold <jbarnold@MIT.EDU> 0.00
70- initial prerelease version
Note: See TracBrowser for help on using the repository browser.