source: branches/locker-dev/locker/bin/scripts-start @ 2284

Last change on this file since 2284 was 2284, checked in by ezyang, 10 years ago
Joomla is known broken with PHP 5.4, removed from install list.
  • Property svn:executable set to *
File size: 723 bytes
Line 
1#!/bin/sh
2
3choices () {
4    echo 'mediawiki MediaWiki'
5    echo 'wordpress WordPress'
6    echo 'gallery2 Gallery2'
7    echo 'phpbb phpBB'
8    echo 'git Git repository'
9    echo 'trac Trac'
10    echo 'turbogears TurboGears'
11    echo 'django Django'
12    echo 'rails Ruby on Rails'
13}
14
15nchoices=`choices | wc -l`
16
17echo
18echo "What piece of software would you like to install?"
19echo
20choices | sed 's/^[^ ]* //' | cat -n
21echo
22printf "Please enter a number 1-%d: " "$nchoices"
23read num
24echo
25
26attach scripts 2>/dev/null
27choice=`choices | sed -n "$num { s/ .*$//; p; }"`
28if [ -n "$choice" ]; then
29  . "/mit/scripts/bin$scriptsdev/scripts-$choice"
30else
31  echo "ERROR:"
32  echo "You must enter a number 1 through $nchoices."
33  exit 1
34fi
Note: See TracBrowser for help on using the repository browser.