1 | # Make sure to update this to coincide with the most recent debathena-discuss |
---|
2 | # release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-discuss/ |
---|
3 | %define upstreamversion 10.0.13 |
---|
4 | Name: discuss |
---|
5 | Version: %{upstreamversion} |
---|
6 | Release: 1.%{scriptsversion}%{?dist} |
---|
7 | Vendor: The scripts.mit.edu Team (scripts@mit.edu) |
---|
8 | Summary: A conferencing and mail archiving system |
---|
9 | Group: Applications/Archiving |
---|
10 | License: MIT |
---|
11 | URL: http://scripts.mit.edu/ |
---|
12 | Source0: debathena-%{name}_%{upstreamversion}.orig.tar.gz |
---|
13 | Source1: discuss.xinetd |
---|
14 | BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX) |
---|
15 | BuildRequires: athena-aclocal, byacc, libcom_err-devel, libss-devel, krb5-devel, zephyr-devel, readline-devel, less |
---|
16 | Requires: less |
---|
17 | |
---|
18 | %description |
---|
19 | Discuss is a user-interface front end to a networked conferencing system. |
---|
20 | This is a clone of Debathena's debathena-discuss package. |
---|
21 | |
---|
22 | %prep |
---|
23 | %setup -q -n debathena-%{name}-%{upstreamversion} |
---|
24 | |
---|
25 | %build |
---|
26 | autoreconf -fi |
---|
27 | # automake doesn't like that there's no Makefile.am, but we're only |
---|
28 | # using it to copy in install-sh and config.{sub|guess}, so we don't |
---|
29 | # want the error return code to cause rpmbuild to bomb out. |
---|
30 | automake --add-missing --foreign || : |
---|
31 | %configure --without-krb4 --with-krb5 --with-zephyr --with-pager=/usr/bin/less |
---|
32 | make %{?_smp_mflags} |
---|
33 | |
---|
34 | %install |
---|
35 | rm -rf %{buildroot} |
---|
36 | make install DESTDIR=%{buildroot} |
---|
37 | # Unfortunately, discuss's build system doesn't presently support |
---|
38 | # building shared libraries, so we won't be installing any of the |
---|
39 | # dev stuff at all just yet. |
---|
40 | rm -rf %{buildroot}%{_includedir} |
---|
41 | rm -rf %{buildroot}%{_libdir} |
---|
42 | mkdir -p %{buildroot}%{_sysconfdir}/xinetd.d |
---|
43 | cp %{SOURCE1} %{buildroot}%{_sysconfdir}/xinetd.d/%{name} |
---|
44 | mkdir -p %{buildroot}%{_localstatedir}/spool/discuss |
---|
45 | |
---|
46 | %clean |
---|
47 | rm -rf %{buildroot} |
---|
48 | |
---|
49 | %files |
---|
50 | %defattr(755,root,root) |
---|
51 | %{_bindir}/crmtgs |
---|
52 | %{_bindir}/discuss |
---|
53 | %{_bindir}/dsc_setup |
---|
54 | %{_bindir}/dsgrep |
---|
55 | %{_bindir}/dsmail |
---|
56 | %{_bindir}/dspipe |
---|
57 | %{_bindir}/mkds |
---|
58 | %{_bindir}/pmtg |
---|
59 | %{_bindir}/rmds |
---|
60 | %{_libexecdir}/edsc |
---|
61 | %defattr(-,root,root,-) |
---|
62 | /usr/share/discuss |
---|
63 | %doc %{_mandir}/man1/*.1.gz |
---|
64 | %doc %{_mandir}/man8/*.8.gz |
---|
65 | |
---|
66 | %post |
---|
67 | if ! grep -q '^discuss[[:space:]]' %{_sysconfdir}/services; then |
---|
68 | cat <<EOF >>%{_sysconfdir}/services |
---|
69 | discuss 2100/tcp # Networked conferencing |
---|
70 | EOF |
---|
71 | fi |
---|
72 | |
---|
73 | %package emacs |
---|
74 | Summary: Emacs interface to discuss |
---|
75 | Group: Applications/Archiving |
---|
76 | Requires: %{name}%{?_isa} = %{version}-%{release}, emacs |
---|
77 | %description emacs |
---|
78 | Discuss is a user-interface front end to a networked conferencing system. |
---|
79 | This package contains an Emacs interface to discuss. |
---|
80 | |
---|
81 | %files emacs |
---|
82 | %defattr(-,root,root,-) |
---|
83 | %{_datadir}/emacs/site-lisp/*.el |
---|
84 | |
---|
85 | %package server |
---|
86 | Summary: A conferencing and mail archiving system |
---|
87 | Group: Applications/Archiving |
---|
88 | Requires(pre): shadow-utils |
---|
89 | Requires: %{name}%{?_isa} = %{version}-%{release}, xinetd |
---|
90 | %description server |
---|
91 | A conferencing and mail archiving system. |
---|
92 | This package contains the discuss server. |
---|
93 | |
---|
94 | %files server |
---|
95 | %defattr(755,root,root) |
---|
96 | %{_bindir}/create_mtg_dir |
---|
97 | %{_sbindir}/discussd |
---|
98 | %attr(4755,discuss,discuss) %{_sbindir}/disserve |
---|
99 | %attr(755,discuss,discuss) %{_localstatedir}/spool/discuss |
---|
100 | %attr(644,root,root) %config(noreplace) %{_sysconfdir}/xinetd.d/%{name} |
---|
101 | |
---|
102 | %pre server |
---|
103 | getent group discuss >/dev/null || groupadd -r discuss |
---|
104 | getent passwd discuss >/dev/null || \ |
---|
105 | useradd -r -M -g discuss -d /var/spool/discuss -s /sbin/nologin \ |
---|
106 | -c "Discuss server" discuss |
---|
107 | exit 0 |
---|
108 | |
---|
109 | %changelog |
---|
110 | * Sun May 29 2011 Mitchell Berger <mitchb@mit.edu> - 10.0.13-1 |
---|
111 | - Initial packaging of Discuss on Fedora |
---|
112 | |
---|