source: branches/fc15-dev/server/fedora/specs/ghc-cgi.spec @ 1833

Last change on this file since 1833 was 1833, checked in by achernya, 13 years ago
Correct ghc-*.spec licenses. @LICENSE@ replaced with BSD for all three.
File size: 2.2 KB
RevLine 
[1826]1# For Haskell Packaging Guidelines see:
2# - https://fedoraproject.org/wiki/Packaging:Haskell
3# - https://fedoraproject.org/wiki/PackagingDrafts/Haskell
4
[1590]5%global pkg_name cgi
6
[1826]7# common part of summary for all the subpackages
[1693]8%global common_summary Haskell %{pkg_name} library
[1590]9
[1826]10# main description used for all the subpackages
[1693]11%global common_description A %{pkg_name} library for Haskell.
12
13# add any Haskell library dependencies here:
14%global ghc_pkg_deps ghc-network-devel, ghc-parsec-devel, ghc-mtl-devel, ghc-MonadCatchIO-mtl-devel, ghc-xhtml-devel
15
[1826]16# Haskell library dependencies (used for buildrequires and devel/prof subpkg requires)
17#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
18
19# foreign library dependencies (used for buildrequires and devel subpkg requires)
[1693]20#%%global ghc_pkg_c_deps @CDEP1@-devel
21
22%bcond_without shared
23
24# debuginfo is not useful for ghc
[1590]25%global debug_package %{nil}
26
27Name:           ghc-%{pkg_name}
[1826]28Version:        3001.1.8.2
[1590]29Release:        0.%{scriptsversion}%{?dist}
[1693]30Summary:        %{common_summary}
[1590]31
[1693]32Group:          System Environment/Libraries
[1833]33License:        BSD
[1826]34URL:            http://hackage.haskell.org/package/%{pkg_name}
[1590]35Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
36# fedora ghc archs:
[1826]37ExclusiveArch:  %{ix86} x86_64 ppc alpha sparcv9
[1693]38BuildRequires:  ghc, ghc-doc, ghc-prof
[1826]39# macros for building haskell packages
40BuildRequires:  ghc-rpm-macros >= 0.7.3
41BuildRequires:  hscolour
[1693]42%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
43%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
[1590]44
45%description
[1693]46%{common_description}
[1590]47
48
49%prep
50%setup -q -n %{pkg_name}-%{version}
51
52
53%build
[1693]54%ghc_lib_build
[1590]55
56
57%install
[1693]58%ghc_lib_install
[1590]59
60
[1826]61# define the devel and prof subpkgs, devel post[un] scripts, and filelists:
62# ghc-%pkg_name{,devel,prof}.files
63%ghc_lib_package
[1590]64
65
66%changelog
[1826]67* Sat Apr 16 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 3001.1.8.2-0
68- regenerated packaging for Fedora automatically generated by cabal2spec-0.22.5
69
[1693]70* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 3001.1.8.1-0
71- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.