1 | Name: zephyr |
---|
2 | Version: 3.0 |
---|
3 | Release: 1.%{scriptsversion}%{?dist} |
---|
4 | Summary: Zephyr allows users to send messages to other users or to groups of users. |
---|
5 | |
---|
6 | Group: Applications/Communications |
---|
7 | License: MIT |
---|
8 | URL: http://zephyr.1ts.org/ |
---|
9 | Source0: http://zephyr.1ts.org/export/HEAD/distribution/%{name}-%{version}.tar.gz |
---|
10 | Source1: zhm.init |
---|
11 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
---|
12 | |
---|
13 | BuildRequires: krb5-devel hesiod-devel libss-devel readline-devel bison |
---|
14 | Requires(post): chkconfig |
---|
15 | Requires(preun): chkconfig |
---|
16 | Requires(preun): initscripts |
---|
17 | Requires(postun): initscripts |
---|
18 | |
---|
19 | %description |
---|
20 | Zephyr is an institutional/enterprise-scale distributed real-time messaging and |
---|
21 | notification system. Zephyr's design choices seem to imbue it with a specific |
---|
22 | culture. It is impossible to explain what Zephyr is, you must experience it |
---|
23 | for yourself. |
---|
24 | |
---|
25 | |
---|
26 | %prep |
---|
27 | %setup -q |
---|
28 | cp -p %{SOURCE1} . |
---|
29 | |
---|
30 | |
---|
31 | %build |
---|
32 | # Mitch wants to make an awesome specfile which makes hesiod/krb5 and friends |
---|
33 | # all fully configurable. This configure line will have to do for now. |
---|
34 | %configure --with-hesiod --with-krb5 |
---|
35 | sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool |
---|
36 | sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
---|
37 | make %{?_smp_mflags} |
---|
38 | |
---|
39 | |
---|
40 | %install |
---|
41 | rm -rf $RPM_BUILD_ROOT |
---|
42 | make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir} |
---|
43 | |
---|
44 | mkdir -p $RPM_BUILD_ROOT%{_initddir} |
---|
45 | install -m755 zhm.init \ |
---|
46 | $RPM_BUILD_ROOT%{_initddir}/zhm |
---|
47 | |
---|
48 | |
---|
49 | %post |
---|
50 | /sbin/chkconfig --add zhm |
---|
51 | |
---|
52 | |
---|
53 | %preun |
---|
54 | if [ $1 = 0 ] ; then |
---|
55 | /sbin/service zhm stop >/dev/null 2>&1 |
---|
56 | /sbin/chkconfig --del zhm |
---|
57 | fi |
---|
58 | |
---|
59 | |
---|
60 | %postun |
---|
61 | if [ "$1" -ge "1" ] ; then |
---|
62 | /sbin/service zhm condrestart >/dev/null 2>&1 || : |
---|
63 | fi |
---|
64 | |
---|
65 | |
---|
66 | %clean |
---|
67 | rm -rf $RPM_BUILD_ROOT |
---|
68 | |
---|
69 | |
---|
70 | %files |
---|
71 | %defattr(-,root,root,-) |
---|
72 | %doc README NOTES OPERATING USING |
---|
73 | %{_bindir}/* |
---|
74 | %{_sbindir}/* |
---|
75 | %{_includedir}/%{name}/ |
---|
76 | %{_libdir}/* |
---|
77 | %{_mandir}/man1/* |
---|
78 | %{_mandir}/man8/* |
---|
79 | %{_datadir}/%{name}/ |
---|
80 | %{_sysconfdir}/%{name}/ |
---|
81 | %{_initddir}/zhm |
---|
82 | |
---|
83 | |
---|
84 | %changelog |
---|
85 | * Thu Sep 09 2010 Edward Z. Yang <ezyang@mit.edu> 3.0-1 |
---|
86 | - Initial packaging release, superseding mit-zephyr. |
---|