Wordpress 3.1
[autoinstalls/wordpress.git] / wp-admin / includes / admin.php
1 <?php
2 /**
3  * Includes all of the WordPress Administration API files.
4  *
5  * @package WordPress
6  * @subpackage Administration
7  */
8
9 /** WordPress Bookmark Administration API */
10 require_once(ABSPATH . 'wp-admin/includes/bookmark.php');
11
12 /** WordPress Comment Administration API */
13 require_once(ABSPATH . 'wp-admin/includes/comment.php');
14
15 /** WordPress Administration File API */
16 require_once(ABSPATH . 'wp-admin/includes/file.php');
17
18 /** WordPress Image Administration API */
19 require_once(ABSPATH . 'wp-admin/includes/image.php');
20
21 /** WordPress Media Administration API */
22 require_once(ABSPATH . 'wp-admin/includes/media.php');
23
24 /** WordPress Import Administration API */
25 require_once(ABSPATH . 'wp-admin/includes/import.php');
26
27 /** WordPress Misc Administration API */
28 require_once(ABSPATH . 'wp-admin/includes/misc.php');
29
30 /** WordPress Plugin Administration API */
31 require_once(ABSPATH . 'wp-admin/includes/plugin.php');
32
33 /** WordPress Post Administration API */
34 require_once(ABSPATH . 'wp-admin/includes/post.php');
35
36 /** WordPress Taxonomy Administration API */
37 require_once(ABSPATH . 'wp-admin/includes/taxonomy.php');
38
39 /** WordPress Template Administration API */
40 require_once(ABSPATH . 'wp-admin/includes/template.php');
41
42 /** WordPress List Table Administration API and base class */
43 require_once(ABSPATH . 'wp-admin/includes/class-wp-list-table.php');
44 require_once(ABSPATH . 'wp-admin/includes/list-table.php');
45
46 /** WordPress Theme Administration API */
47 require_once(ABSPATH . 'wp-admin/includes/theme.php');
48
49 /** WordPress User Administration API */
50 require_once(ABSPATH . 'wp-admin/includes/user.php');
51
52 /** WordPress Update Administration API */
53 require_once(ABSPATH . 'wp-admin/includes/update.php');
54
55 /** WordPress Deprecated Administration API */
56 require_once(ABSPATH . 'wp-admin/includes/deprecated.php');
57
58 /** WordPress Multi-Site support API */
59 if ( is_multisite() ) {
60         require_once(ABSPATH . 'wp-admin/includes/ms.php');
61         require_once(ABSPATH . 'wp-admin/includes/ms-deprecated.php');
62 }
63
64 ?>