Custom Query (196 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (7 - 9 of 196)

1 2 3 4 5 6 7 8 9 10 11 12 13
Ticket Resolution Summary Owner Reporter
#30 wontfix upgrade nss_ldap out of a vulnerability price
Description

Quentin writes: """We are probably being affected by this. We currently have nss_ldap-257-3 installed, which may or may not include the patch that's in -258 to fix this.""" and forwards the email below.

Was https://help.mit.edu/?q=531080.


Date: Sun, 25 Nov 2007 22:43:56 +0100 From: Pierre-Yves Rofes <py@…> To: gentoo-announce@… Cc: full-disclosure@…, bugtraq@…, security-alerts@… Subject: [gentoo-announce] [ GLSA 200711-33 ] nss_ldap: Information disclosure


Hash: SHA1

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Gentoo Linux Security Advisory GLSA 200711-33

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

http://security.gentoo.org/

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Low Title: nss_ldap: Information disclosure Date: November 25, 2007 Bugs: #198390 ID: 200711-33

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis ========

A race condition might lead to theft of user credentials or information disclosure in services using nss_ldap.

Background ==========

nss_ldap is a Name Service Switch module which allows 'passwd', 'group' and 'host' database information to be pulled from LDAP.

Affected packages =================


Package / Vulnerable / Unaffected


1 sys-auth/nss_ldap < 258 >= 258

Description ===========

Josh Burley reported that nss_ldap does not properly handle the LDAP connections due to a race condition that can be triggered by multi-threaded applications using nss_ldap, which might lead to requested data being returned to a wrong process.

Impact ======

Remote attackers could exploit this race condition by sending queries to a vulnerable server using nss_ldap, possibly leading to theft of user credentials or information disclosure (e.g. Dovecot returning wrong mailbox contents).

Workaround ==========

There is no known workaround at this time.

Resolution ==========

All nss_ldap users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=sys-auth/nss_ldap-258"

References ==========

[ 1 ] CVE-2007-5794 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5794

Availability ============

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200711-33.xml

Concerns? =========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@… or alternatively, you may file a bug at http://bugs.gentoo.org.

License =======

Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


Version: GnuPG v1.4.7 (GNU/Linux) Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHSeycuhJ+ozIKI5gRAjvwAKCc3Et4rezJasP3RT7sWY+pHyShwACfVwbg 67oYKwgTwEYBnnY/v5ZQ5zw= =TEDE


-- gentoo-announce@… mailing list

#26 fixed upgrade PCRE, if it's old enough to be vulnerable quentin price
Description

Some version of PCRE is vulnerable. Are we affected?

Was https://help.mit.edu/?q=530046.

Quentin forwarded the following email:


Date: Tue, 20 Nov 2007 22:44:46 +0100 From: Pierre-Yves Rofes <py@…> To: gentoo-announce@… Cc: full-disclosure@…, bugtraq@…, security-alerts@… Subject: [gentoo-announce] [ GLSA 200711-30 ] PCRE: Multiple vulnerabilities


Hash: SHA1

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Gentoo Linux Security Advisory GLSA 200711-30

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

http://security.gentoo.org/

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Severity: Normal Title: PCRE: Multiple vulnerabilities Date: November 20, 2007 Bugs: #198198 ID: 200711-30

  • - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis ========

PCRE is vulnerable to multiple buffer overflow and memory corruption vulnerabilities, possibly leading to the execution of arbitrary code.

Background ==========

PCRE is a library providing functions for Perl-compatible regular expressions.

Affected packages =================


Package / Vulnerable / Unaffected


1 dev-libs/libpcre < 7.3-r1 >= 7.3-r1

Description ===========

Tavis Ormandy (Google Security) discovered multiple vulnerabilities in PCRE. He reported an error when processing "\Q\E" sequences with unmatched "\E" codes that can lead to the compiled bytecode being corrupted (CVE-2007-1659). PCRE does not properly calculate sizes for unspecified "multiple forms of character class", which triggers a buffer overflow (CVE-2007-1660). Further improper calculations of memory boundaries were reported when matching certain input bytes against regex patterns in non UTF-8 mode (CVE-2007-1661) and when searching for unmatched brackets or parentheses (CVE-2007-1662). Multiple integer overflows when processing escape sequences may lead to invalid memory read operations or potentially cause heap-based buffer overflows (CVE-2007-4766). PCRE does not properly handle "\P" and "\P{x}" sequences which can lead to heap-based buffer overflows or trigger the execution of infinite loops (CVE-2007-4767), PCRE is also prone to an error when optimizing character classes containing a singleton UTF-8 sequence which might lead to a heap-based buffer overflow (CVE-2007-4768).

Chris Evans also reported multiple integer overflow vulnerabilities in PCRE when processing a large number of named subpatterns ("name_count") or long subpattern names ("max_name_size") (CVE-2006-7227), and via large "min", "max", or "duplength" values (CVE-2006-7228) both possibly leading to buffer overflows. Another vulnerability was reported when compiling patterns where the "-x" or "-i" UTF-8 options change within the pattern, which might lead to improper memory calculations (CVE-2006-7230).

Impact ======

An attacker could exploit these vulnerabilities by sending specially crafted regular expressions to applications making use of the PCRE library, which could possibly lead to the execution of arbitrary code, a Denial of Service or the disclosure of sensitive information.

Workaround ==========

There is no known workaround at this time.

Resolution ==========

All PCRE users should upgrade to the latest version:

# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/libpcre-7.3-r1"

References ==========

[ 1 ] CVE-2006-7227 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-7227 [ 2 ] CVE-2006-7228 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-7228 [ 3 ] CVE-2006-7230 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-7230 [ 4 ] CVE-2007-1659 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1659 [ 5 ] CVE-2007-1660 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1660 [ 6 ] CVE-2007-1661 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1661 [ 7 ] CVE-2007-1662 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-1662 [ 8 ] CVE-2007-4766 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4766 [ 9 ] CVE-2007-4767 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4767 [ 10 ] CVE-2007-4768 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-4768

Availability ============

This GLSA and any updates to it are available for viewing at the Gentoo Security Website:

http://security.gentoo.org/glsa/glsa-200711-30.xml

Concerns? =========

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@… or alternatively, you may file a bug at http://bugs.gentoo.org.

License =======

Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).

The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.5


Version: GnuPG v1.4.7 (GNU/Linux) Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFHQ1VNuhJ+ozIKI5gRArV7AJ0XnRsp7sCapeuBni8l+0dSCBSnoQCfcagD 23VxdHrTAY0sl0lLSXLLwHU= =srdq


-- gentoo-announce@… mailing list

#53 fixed upgrade Gallery installer price
Description

We have an installer for Gallery 2.0. Gallery 2.1 and 2.2 now exist.

The 2.1 release notes and 2.2 release notes describe a number of user-desirable new features, plus security fixes.

Let's upgrade -- first roll out a new installer so new users are happy, then look at upgrading existing instances.

1 2 3 4 5 6 7 8 9 10 11 12 13
Note: See TracQuery for help on using queries.