1 | Name: zephyr |
---|
2 | Version: 3.0 |
---|
3 | Release: 0.%{scriptsversion}%{?dist} |
---|
4 | Summary: Client programs for the Zephyr real-time messaging system |
---|
5 | |
---|
6 | Group: Applications/Communications |
---|
7 | License: MIT |
---|
8 | URL: http://zephyr.1ts.org/ |
---|
9 | Source0: http://zephyr.1ts.org/export/HEAD/distribution/%{name}-%{version}.tar.gz |
---|
10 | Source1: zhm.init |
---|
11 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
---|
12 | |
---|
13 | BuildRequires: krb5-devel hesiod-devel libss-devel libcom_err-devel readline-devel bison |
---|
14 | Requires: %{name}-libs = %{version}-%{release} |
---|
15 | Requires(post): chkconfig |
---|
16 | Requires(preun): chkconfig |
---|
17 | Requires(preun): initscripts |
---|
18 | Requires(postun): initscripts |
---|
19 | |
---|
20 | %description |
---|
21 | Zephyr is an institutional/enterprise-scale distributed real-time messaging and |
---|
22 | notification system. Zephyr's design choices seem to imbue it with a specific |
---|
23 | culture. It is impossible to explain what Zephyr is, you must experience it |
---|
24 | for yourself. |
---|
25 | |
---|
26 | |
---|
27 | %package server |
---|
28 | Summary: Server for the Zephyr real-time messaging system |
---|
29 | Group: System Environment/Daemons |
---|
30 | |
---|
31 | Requires: %{name}-libs = %{version}-%{release} |
---|
32 | |
---|
33 | %description server |
---|
34 | The %{name}-server package contains the server daemon for the Zephyr |
---|
35 | messaging service. It maintains a location and subscription database |
---|
36 | for all the receiving clients, and routes all zephyrgrams to the |
---|
37 | intended recipients. |
---|
38 | |
---|
39 | |
---|
40 | %package libs |
---|
41 | Summary: Shared libraries for Zephyr real-time messaging system |
---|
42 | Group: System Environment/Libraries |
---|
43 | |
---|
44 | %description libs |
---|
45 | The %{name}-libs package contains shared libraries for applications |
---|
46 | that use %{name}. |
---|
47 | |
---|
48 | |
---|
49 | %package devel |
---|
50 | Summary: Development files for Zephyr real-time messaging system |
---|
51 | Group: Development/Libraries |
---|
52 | |
---|
53 | Requires: %{name}-libs = %{version}-%{release}, libcom_err-devel |
---|
54 | |
---|
55 | %description devel |
---|
56 | The %{name}-devel package contains libraries and header files for |
---|
57 | developing applications that use %{name}. |
---|
58 | |
---|
59 | |
---|
60 | %prep |
---|
61 | %setup -q |
---|
62 | cp -p %{SOURCE1} . |
---|
63 | |
---|
64 | |
---|
65 | %build |
---|
66 | # Mitch wants to make an awesome specfile which makes hesiod/krb5 and friends |
---|
67 | # all fully configurable. This configure line will have to do for now. |
---|
68 | %configure --with-hesiod --with-krb5 --disable-static |
---|
69 | sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool |
---|
70 | sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
---|
71 | make %{?_smp_mflags} |
---|
72 | |
---|
73 | |
---|
74 | %install |
---|
75 | rm -rf $RPM_BUILD_ROOT |
---|
76 | make install DESTDIR=$RPM_BUILD_ROOT libdir=%{_libdir} |
---|
77 | find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';' |
---|
78 | |
---|
79 | mkdir -p $RPM_BUILD_ROOT%{_initddir} |
---|
80 | install -m755 zhm.init \ |
---|
81 | $RPM_BUILD_ROOT%{_initddir}/zhm |
---|
82 | |
---|
83 | |
---|
84 | %post |
---|
85 | /sbin/chkconfig --add zhm |
---|
86 | |
---|
87 | |
---|
88 | %preun |
---|
89 | if [ $1 = 0 ] ; then |
---|
90 | /sbin/service zhm stop >/dev/null 2>&1 |
---|
91 | /sbin/chkconfig --del zhm |
---|
92 | fi |
---|
93 | |
---|
94 | |
---|
95 | %postun |
---|
96 | if [ "$1" -ge "1" ] ; then |
---|
97 | /sbin/service zhm condrestart >/dev/null 2>&1 || : |
---|
98 | fi |
---|
99 | |
---|
100 | |
---|
101 | %post libs -p /sbin/ldconfig |
---|
102 | |
---|
103 | %postun libs -p /sbin/ldconfig |
---|
104 | |
---|
105 | |
---|
106 | %clean |
---|
107 | rm -rf $RPM_BUILD_ROOT |
---|
108 | |
---|
109 | |
---|
110 | %files |
---|
111 | %defattr(-,root,root,-) |
---|
112 | %doc README USING |
---|
113 | %{_bindir}/* |
---|
114 | %{_sbindir}/zhm |
---|
115 | %{_sbindir}/zshutdown_notify |
---|
116 | %{_mandir}/man1/* |
---|
117 | %{_mandir}/man8/zhm.8* |
---|
118 | %{_mandir}/man8/zstat.8* |
---|
119 | %{_mandir}/man8/zshutdown_notify.8* |
---|
120 | %{_datadir}/zephyr |
---|
121 | %{_initddir}/zhm |
---|
122 | |
---|
123 | |
---|
124 | %files server |
---|
125 | %doc OPERATING |
---|
126 | %{_sysconfdir}/zephyr |
---|
127 | %{_sbindir}/zephyrd |
---|
128 | %{_mandir}/man8/zephyrd.8* |
---|
129 | |
---|
130 | |
---|
131 | %files libs |
---|
132 | %{_libdir}/*.so.* |
---|
133 | |
---|
134 | |
---|
135 | %files devel |
---|
136 | %{_libdir}/*.so |
---|
137 | %{_includedir}/* |
---|
138 | |
---|
139 | |
---|
140 | %changelog |
---|
141 | * Sun Sep 19 2010 Anders Kaseorg <andersk@mit.edu> - 3.0-0 |
---|
142 | - Decrease version below a hypothetical Fedora package. |
---|
143 | - Split out -server, -libs, and -devel into subpackages. |
---|
144 | - Disable the static library and remove the libtool archive. |
---|
145 | |
---|
146 | * Thu Sep 09 2010 Edward Z. Yang <ezyang@mit.edu> 3.0-1 |
---|
147 | - Initial packaging release, superseding mit-zephyr. |
---|