source: trunk/server/fedora/specs/rubygem-fcgi.spec @ 2762

Last change on this file since 2762 was 2591, checked in by achernya, 10 years ago
Reintegrate fc20-dev into trunk
File size: 2.2 KB
Line 
1# Generated from fcgi-0.9.1.gem by gem2rpm -*- rpm-spec -*-
2%global gem_name fcgi
3
4Name: rubygem-%{gem_name}
5Version: 0.9.2.1
6Release: 1.scripts.%{scriptsversion}%{?dist}
7Summary: FastCGI library for Ruby
8Group: Development/Languages
9License: BSDL
10URL: http://github.com/alphallc/ruby-fcgi-ng
11Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem
12Requires: ruby(release)
13Requires: ruby(rubygems)
14Requires: fcgi-devel
15BuildRequires: ruby(release)
16BuildRequires: rubygems-devel
17BuildRequires: ruby-devel
18BuildRequires: fcgi-devel
19Provides: rubygem(%{gem_name}) = %{version}
20
21%description
22FastCGI is a language independent, scalable, open extension to CGI that
23provides high performance without the limitations of server specific APIs.
24This version aims to be compatible with both 1.8.x and 1.9.x versions of Ruby,
25and also will be ported to 2.0.x.
26
27
28%package doc
29Summary: Documentation for %{name}
30Group: Documentation
31Requires: %{name} = %{version}-%{release}
32BuildArch: noarch
33
34%description doc
35Documentation for %{name}
36
37%prep
38gem unpack %{SOURCE0}
39
40%setup -q -D -T -n  %{gem_name}-%{version}
41
42gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec
43
44%build
45# Create the gem as gem install only works on a gem file
46gem build %{gem_name}.gemspec
47
48# %%gem_install compiles any C extensions and installs the gem into ./%gem_dir
49# by default, so that we can move it into the buildroot in %%install
50%gem_install
51
52%install
53mkdir -p %{buildroot}%{gem_dir}
54cp -pa .%{gem_dir}/* \
55        %{buildroot}%{gem_dir}/
56
57mkdir -p %{buildroot}%{gem_extdir_mri}/lib
58# TODO: move the extensions
59# mv %{buildroot}%{gem_instdir}/lib/shared_object.so %{buildroot}%{gem_extdir_mri}/lib/
60
61
62
63%files
64%dir %{gem_instdir}
65%{gem_libdir}
66%exclude %{gem_instdir}/ext
67%{gem_extdir_mri}
68%exclude %{gem_cache}
69%{gem_spec}
70
71%files doc
72%doc %{gem_docdir}
73%doc %{gem_instdir}/VERSION
74%doc %{gem_instdir}/LICENSE
75%doc %{gem_instdir}/README.rdoc
76%doc %{gem_instdir}/README.signals
77%{gem_instdir}/fcgi.gemspec
78%{gem_instdir}/test/helper.rb
79%{gem_instdir}/test/test_fcgi.rb
80
81%changelog
82* Sat Jul 19 2014 Benjamin Tidor <btidor@mit.edu> - 0.9.2.1-1
83- Updated to 0.9.2.1, reconfigured for Sscripts
84
85* Mon Aug 12 2013 Steven Valdez <dvorak42@XVM-THREE-199.MIT.EDU> - 0.9.1-1
86- Initial package
Note: See TracBrowser for help on using the repository browser.