1 | # Generated from fcgi-0.9.1.gem by gem2rpm -*- rpm-spec -*- |
---|
2 | %global gem_name fcgi |
---|
3 | |
---|
4 | Name: rubygem-%{gem_name} |
---|
5 | Version: 0.9.2.1 |
---|
6 | Release: 1.scripts.%{scriptsversion}%{?dist} |
---|
7 | Summary: FastCGI library for Ruby |
---|
8 | Group: Development/Languages |
---|
9 | License: BSDL |
---|
10 | URL: http://github.com/alphallc/ruby-fcgi-ng |
---|
11 | Source0: https://rubygems.org/gems/%{gem_name}-%{version}.gem |
---|
12 | Requires: ruby(release) |
---|
13 | Requires: ruby(rubygems) |
---|
14 | Requires: fcgi-devel |
---|
15 | BuildRequires: ruby(release) |
---|
16 | BuildRequires: rubygems-devel |
---|
17 | BuildRequires: ruby-devel |
---|
18 | BuildRequires: fcgi-devel |
---|
19 | Provides: rubygem(%{gem_name}) = %{version} |
---|
20 | |
---|
21 | %description |
---|
22 | FastCGI is a language independent, scalable, open extension to CGI that |
---|
23 | provides high performance without the limitations of server specific APIs. |
---|
24 | This version aims to be compatible with both 1.8.x and 1.9.x versions of Ruby, |
---|
25 | and also will be ported to 2.0.x. |
---|
26 | |
---|
27 | |
---|
28 | %package doc |
---|
29 | Summary: Documentation for %{name} |
---|
30 | Group: Documentation |
---|
31 | Requires: %{name} = %{version}-%{release} |
---|
32 | BuildArch: noarch |
---|
33 | |
---|
34 | %description doc |
---|
35 | Documentation for %{name} |
---|
36 | |
---|
37 | %prep |
---|
38 | gem unpack %{SOURCE0} |
---|
39 | |
---|
40 | %setup -q -D -T -n %{gem_name}-%{version} |
---|
41 | |
---|
42 | gem spec %{SOURCE0} -l --ruby > %{gem_name}.gemspec |
---|
43 | |
---|
44 | %build |
---|
45 | # Create the gem as gem install only works on a gem file |
---|
46 | gem build %{gem_name}.gemspec |
---|
47 | |
---|
48 | # %%gem_install compiles any C extensions and installs the gem into ./%gem_dir |
---|
49 | # by default, so that we can move it into the buildroot in %%install |
---|
50 | %gem_install |
---|
51 | |
---|
52 | %install |
---|
53 | mkdir -p %{buildroot}%{gem_dir} |
---|
54 | cp -pa .%{gem_dir}/* \ |
---|
55 | %{buildroot}%{gem_dir}/ |
---|
56 | |
---|
57 | mkdir -p %{buildroot}%{gem_extdir_mri}/lib |
---|
58 | # TODO: move the extensions |
---|
59 | # mv %{buildroot}%{gem_instdir}/lib/shared_object.so %{buildroot}%{gem_extdir_mri}/lib/ |
---|
60 | |
---|
61 | |
---|
62 | |
---|
63 | %files |
---|
64 | %dir %{gem_instdir} |
---|
65 | %{gem_libdir} |
---|
66 | %exclude %{gem_instdir}/ext |
---|
67 | %{gem_extdir_mri} |
---|
68 | %exclude %{gem_cache} |
---|
69 | %{gem_spec} |
---|
70 | |
---|
71 | %files doc |
---|
72 | %doc %{gem_docdir} |
---|
73 | %doc %{gem_instdir}/VERSION |
---|
74 | %doc %{gem_instdir}/LICENSE |
---|
75 | %doc %{gem_instdir}/README.rdoc |
---|
76 | %doc %{gem_instdir}/README.signals |
---|
77 | %{gem_instdir}/fcgi.gemspec |
---|
78 | %{gem_instdir}/test/helper.rb |
---|
79 | %{gem_instdir}/test/test_fcgi.rb |
---|
80 | |
---|
81 | %changelog |
---|
82 | * Sat Jul 19 2014 Benjamin Tidor <btidor@mit.edu> - 0.9.2.1-1 |
---|
83 | - Updated to 0.9.2.1, reconfigured for Sscripts |
---|
84 | |
---|
85 | * Mon Aug 12 2013 Steven Valdez <dvorak42@XVM-THREE-199.MIT.EDU> - 0.9.1-1 |
---|
86 | - Initial package |
---|