source: trunk/server/fedora/specs/python-authkit.spec @ 2799

Last change on this file since 2799 was 2591, checked in by achernya, 10 years ago
Reintegrate fc20-dev into trunk
File size: 1.9 KB
Line 
1# sitelib for noarch packages, sitearch for others (remove the unneeded one)
2%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
3%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
4
5Name:           python-authkit
6Version:        0.4.5
7Release:        2%{?dist}
8Summary:        An authentication and authorization toolkit for WSGI applications and frameworks
9
10License:        MIT
11URL:            https://pypi.python.org/pypi/AuthKit/0.4.5
12Source0:        https://pypi.python.org/packages/source/A/AuthKit/AuthKit-0.4.5.tar.gz
13
14BuildArch:      noarch
15
16BuildRequires:  python-setuptools
17BuildRequires:  python2-devel
18
19Requires:       python-beaker
20Requires:       python-decorator
21Requires:       python-nose
22Requires:       python-openid
23Requires:       python-paste
24Requires:       python-paste-deploy
25Requires:       python-paste-script
26Requires:       python-webob
27
28Patch0:         python-authkit.patch
29
30%description
31* Built for WSGI applications and middleware
32* Sophisticated and extensible permissions system
33* Built in support for HTTP basic, HTTP digest, form, cookie and
34  OpenID authentication methods plus others
35* Easily define users, passwords and roles
36* Designed to be totally extensible so you can use the components to
37  integrate with a database, LDAP connection or your own custom system
38* Plays nicely with the Pylons web framework
39
40
41%prep
42%setup -q -n AuthKit-%{version}
43%patch0 -p1
44
45
46%build
47# Remove CFLAGS=... for noarch packages (unneeded)
48CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53%{__python} setup.py install -O1 --skip-build --root $RPM_BUILD_ROOT
54
55 
56%files
57%doc
58# For noarch packages: sitelib
59%{python_sitelib}/*
60
61
62%changelog
63* Thu Aug 28 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.4.5-2
64- Correct ElementTree import.
65
66* Thu Aug 28 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.4.5-1
67- Initial packaging.
Note: See TracBrowser for help on using the repository browser.