source: trunk/server/fedora/specs/moira.spec @ 1710

Last change on this file since 1710 was 1535, checked in by mitchb, 14 years ago
Update moira snapshot
File size: 7.8 KB
RevLine 
[1396]1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
[1397]3%define upstreamversion 4.0.0
[1535]4%define snapshotversion svn20100405
[1399]5Summary: moira libraries, clients, and friends
[1394]6Group: Applications/System
7Name: moira
[1397]8Version: %{upstreamversion}
[1535]9Release: 6.%{scriptsversion}.%{snapshotversion}
[1394]10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
[1396]12License: MIT
[1397]13Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz
[1394]14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
[1402]16BuildRequires: readline-devel, e2fsprogs-devel, ncurses-devel, krb5-devel, hesiod-devel
[1396]17Patch1: moira-update-server.rc.patch
[1406]18Patch2: moira-fix-manpage-paths.patch
[1394]19
20%description
[1399]21The moira library and clients.  Clone of debathena-moira.
[1394]22See http://scripts.mit.edu/wiki for more information.
23
24%prep
[1397]25%setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion}
[1396]26%patch1
[1406]27%patch2 -p1
[1394]28
29%build
30# Hack: Add /usr/include/et to put com_err.h on the C include path.
31# Can remove this once the maintainer of the relevant package symlinks
32# com_err.h in /usr/include.
[1406]33# (See https://bugzilla.redhat.com/show_bug.cgi?id=550889)
[1394]34# TODO: --with-zephyr is currently borked
35%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
36make %{?_smp_mflags}
37
38%install
39rm -rf %{buildroot}
40make install DESTDIR=%{buildroot}
41mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
42mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
43mv %{buildroot}/%{_mandir}/man1/chsh.1 \
44   %{buildroot}/%{_mandir}/man1/chsh.moira.1
45mv %{buildroot}/%{_mandir}/man1/chfn.1 \
46   %{buildroot}/%{_mandir}/man1/chfn.moira.1
47install -m 755 -d %{buildroot}/%{_initddir}
[1396]48install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
[1394]49# Hack: These man files are installed but no package uses them
50rm %{buildroot}/%{_mandir}/man8/dcm.8
51rm %{buildroot}/%{_mandir}/man8/moirad.8
52rm %{buildroot}/%{_mandir}/man8/reg_svr.8
53rm %{buildroot}/%{_mandir}/man8/setquota.8
54rm %{buildroot}/%{_mandir}/man8/startdcm.8
55rm %{buildroot}/%{_mandir}/man8/startmoira.8
56rm %{buildroot}/%{_mandir}/man8/startreg.8
57
58%clean
59rm -rf %{buildroot}
60
[1396]61# clients
62%package clients
[1394]63Summary: Clients for the Moira database
64Group: Applications/System
[1397]65# Might need mit-zephyr-devel
66# Requires: mit-zephyr
[1396]67%description clients
[1394]68Moira is the Athena Service Management system.  It serves as the
69central repository for information about users, groups hosts, print
70queues, and several other aspects of the Athena environment.
71
72This package contains clients such as moira, stella, blanche, etc.
73
[1396]74%files clients
75%defattr(755,root,root)
[1394]76%{_bindir}/addusr
77%{_bindir}/blanche
78%{_bindir}/chfn.moira
79%{_bindir}/chpobox
80%{_bindir}/chsh.moira
[1403]81%{_bindir}/eunice
[1394]82%{_bindir}/mitch
83%{_bindir}/namespace
84%{_bindir}/moira
85%{_bindir}/mrcheck
86%{_bindir}/mrtest
87%{_bindir}/stanley
88%{_bindir}/stella
89%{_bindir}/mailmaint
90%{_bindir}/listmaint
91%{_bindir}/dcmmaint
92%{_bindir}/usermaint
93%{_bindir}/update_test
[1396]94%defattr(-,root,root)
[1394]95%doc %{_mandir}/man1/*
96%doc %{_mandir}/man8/mrtest.8.gz
97
98
[1396]99# update-server
100%package update-server
[1394]101Summary: Athena update_server
102Group: Applications/System
[1397]103# Might need mit-zephyr-devel
104# Requires: mit-zephyr
[1394]105Requires(post): chkconfig
106Requires(preun): chkconfig
[1396]107%description update-server
[1394]108Moira is the Athena Service Management system.  It serves as the
109central repository for information about users, groups hosts, print
110queues, and several other aspects of the Athena environment.
111
112This package contains the update_server daemon, which is used for
113servers that automatically receive information dumps from moira.
114
[1396]115%files update-server
[1394]116%defattr(-,root,root)
117%doc %{_mandir}/man8/update_server.8.gz
[1406]118%config(noreplace) %{_sysconfdir}/moira.conf
[1394]119%defattr(755,root,root)
120%{_sbindir}/update_server
121%{_initddir}/moira-update-server
122
[1396]123%post update-server
[1394]124/sbin/chkconfig --add moira-update-server
[1396]125%{_initddir}/moira-update-server condrestart
[1394]126
[1396]127%preun update-server
[1394]128if [ $1 = 0 ] ; then
129    /sbin/service moira-update-server stop >/dev/null 2>&1
130    /sbin/chkconfig --del moira-update-server
131fi
132
133# libmoira0
[1396]134%package -n libmoira0
[1394]135Summary: The Moira library
136Group: System Environment/Libraries
[1396]137%description -n libmoira0
[1394]138Moira is the Athena Service Management system.  It serves as the
139central repository for information about users, groups hosts, print
140queues, and several other aspects of the Athena environment.
141
142This package contains the shared Moira library.
143
[1396]144%post -n libmoira0 -p /sbin/ldconfig
145%postun -n libmoira0 -p /sbin/ldconfig
146
147%files -n libmoira0
148%defattr(-,root,root)
[1394]149%{_libdir}/libmoira.so.*
150
[1396]151# libmoira-devel
152%package -n libmoira-devel
[1394]153Summary: Development files for Moira library
154Group: Development/Libraries
[1397]155# Might need mit-zephyr-devel
156# Requires: mit-zephyr
157Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel
[1396]158%description -n libmoira-devel
[1394]159Moira is the Athena Service Management system.  It serves as the
160central repository for information about users, groups hosts, print
161queues, and several other aspects of the Athena environment.
162
163This package contains headers and static libraries for development.
164
[1396]165%post -n libmoira-devel -p /sbin/ldconfig
166%postun -n libmoira-devel -p /sbin/ldconfig
167
168%files -n libmoira-devel
[1394]169%defattr(-,root,root)
[1406]170%{_includedir}/moira
171%exclude %{_includedir}/moira/mrclient.h
[1394]172%doc %{_mandir}/man3/*
173%{_libdir}/libmoira.so
174%{_libdir}/libmoira.la
175%{_libdir}/libmoira.a
[1396]176
[1406]177# libmrclient0
178%package -n libmrclient0
179Summary: The Moira client library
180Group: System Environment/Libraries
181%description -n libmrclient0
182Moira is the Athena Service Management system.  It serves as the
183central repository for information about users, groups hosts, print
184queues, and several other aspects of the Athena environment.
185
186This package contains the shared Moira client library.
187
188%post -n libmrclient0 -p /sbin/ldconfig
189%postun -n libmrclient0 -p /sbin/ldconfig
190
191%files -n libmrclient0
192%defattr(-,root,root)
193%{_libdir}/libmrclient.so.*
194
195# libmrclient-devel
196%package -n libmrclient-devel
197Summary: Development files for Moira client library
198Group: Development/Libraries
199Requires: libmrclient0 = %{version}-%{release}, libmoira-devel = %{version}-%{release}
200%description -n libmrclient-devel
201Moira is the Athena Service Management system.  It serves as the
202central repository for information about users, groups hosts, print
203queues, and several other aspects of the Athena environment.
204
205This package contains headers and static libraries for development.
206
207%post -n libmrclient-devel -p /sbin/ldconfig
208%postun -n libmrclient-devel -p /sbin/ldconfig
209
210%files -n libmrclient-devel
211%defattr(-,root,root)
212%{_includedir}/moira/mrclient.h
213%{_libdir}/libmrclient.so
214%{_libdir}/libmrclient.la
215%{_libdir}/libmrclient.a
216
[1396]217%changelog
[1535]218* Thu Apr 08 2010 Mitchell Berger <mitchb@mit.edu> - 4.0.0-6.1534.svn20100405
219- Update to new original upstream version (svn snapshot)
220
[1491]221* Thu Feb 25 2010 Mitchell Berger <mitchb@mit.edu> - 4.0.0-5.1490.svn20100225
222- Update to new original upstream version (svn snapshot)
223
[1490]224* Thu Feb 25 2010 Mitchell Berger <mitchb@mit.edu> - 4.0.0-4.1489M.svn20100223
225- Update to new original upstream version (svn snapshot)
226- Drop install-headers patch which was incorporated upstream (from Debathena)
227
[1406]228* Tue Jan 05 2010 Mitchell Berger <mitchb@mit.edu> - 4.0.0-3.1405M.svn20100104
229- Update to new original upstream version (svn snapshot)
230- Build and install libmrclient as a shared library (from Debathena)
231
[1403]232* Mon Dec 28 2009 Mitchell Berger <mitchb@mit.edu> - 4.0.0-2.1402.cvs20091228
233- Update to new upstream version, including eunice printer client
234
[1396]235* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
236- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.