source: trunk/server/fedora/specs/moira.spec @ 1403

Last change on this file since 1403 was 1403, checked in by mitchb, 14 years ago
Update moira to new upstream version, including eunice printer client
File size: 5.7 KB
RevLine 
[1396]1# Make sure to update these to coincide with the most recent debathena-moira
2# release from http://debathena.mit.edu/apt/pool/debathena/d/debathena-moira/
[1397]3%define upstreamversion 4.0.0
[1403]4%define snapshotversion cvs20091228
[1399]5Summary: moira libraries, clients, and friends
[1394]6Group: Applications/System
7Name: moira
[1397]8Version: %{upstreamversion}
[1403]9Release: 2.%{scriptsversion}.%{snapshotversion}
[1394]10Vendor: The scripts.mit.edu Team (scripts@mit.edu)
11URL: http://scripts.mit.edu
[1396]12License: MIT
[1397]13Source: debathena-%{name}_%{upstreamversion}+%{snapshotversion}.orig.tar.gz
[1394]14BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
15#TODO: might really need mit-zephyr-devel, something for autotools-dev
[1402]16BuildRequires: readline-devel, e2fsprogs-devel, ncurses-devel, krb5-devel, hesiod-devel
[1396]17Patch0: moira-install-headers.patch
18Patch1: moira-update-server.rc.patch
[1394]19
20%description
[1399]21The moira library and clients.  Clone of debathena-moira.
[1394]22See http://scripts.mit.edu/wiki for more information.
23
24%prep
[1397]25%setup -q -n debathena-%{name}-%{upstreamversion}+%{snapshotversion}
[1394]26%patch0 -p1
[1396]27%patch1
[1394]28
29%build
30# Hack: Add /usr/include/et to put com_err.h on the C include path.
31# Can remove this once the maintainer of the relevant package symlinks
32# com_err.h in /usr/include.
33# TODO: --with-zephyr is currently borked
34%configure --without-krb4 --with-krb5 --with-hesiod --without-zephyr --without-oracle --without-afs --disable-rpath --with-com_err=/usr CFLAGS='-I /usr/include/et'
35make %{?_smp_mflags}
36
37%install
38rm -rf %{buildroot}
39make install DESTDIR=%{buildroot}
40mv %{buildroot}/%{_bindir}/chfn %{buildroot}/%{_bindir}/chfn.moira
41mv %{buildroot}/%{_bindir}/chsh %{buildroot}/%{_bindir}/chsh.moira
42mv %{buildroot}/%{_mandir}/man1/chsh.1 \
43   %{buildroot}/%{_mandir}/man1/chsh.moira.1
44mv %{buildroot}/%{_mandir}/man1/chfn.1 \
45   %{buildroot}/%{_mandir}/man1/chfn.moira.1
46install -m 755 -d %{buildroot}/%{_initddir}
[1396]47install -m 755 moira-update-server.init %{buildroot}/%{_initddir}/moira-update-server
[1394]48# Hack: These man files are installed but no package uses them
49rm %{buildroot}/%{_mandir}/man8/dcm.8
50rm %{buildroot}/%{_mandir}/man8/moirad.8
51rm %{buildroot}/%{_mandir}/man8/reg_svr.8
52rm %{buildroot}/%{_mandir}/man8/setquota.8
53rm %{buildroot}/%{_mandir}/man8/startdcm.8
54rm %{buildroot}/%{_mandir}/man8/startmoira.8
55rm %{buildroot}/%{_mandir}/man8/startreg.8
56
57%clean
58rm -rf %{buildroot}
59
[1396]60# clients
61%package clients
[1394]62Summary: Clients for the Moira database
63Group: Applications/System
[1397]64# Might need mit-zephyr-devel
65# Requires: mit-zephyr
[1396]66%description clients
[1394]67Moira is the Athena Service Management system.  It serves as the
68central repository for information about users, groups hosts, print
69queues, and several other aspects of the Athena environment.
70
71This package contains clients such as moira, stella, blanche, etc.
72
[1396]73%files clients
74%defattr(755,root,root)
[1394]75%{_bindir}/addusr
76%{_bindir}/blanche
77%{_bindir}/chfn.moira
78%{_bindir}/chpobox
79%{_bindir}/chsh.moira
[1403]80%{_bindir}/eunice
[1394]81%{_bindir}/mitch
82%{_bindir}/namespace
83%{_bindir}/moira
84%{_bindir}/mrcheck
85%{_bindir}/mrtest
86%{_bindir}/stanley
87%{_bindir}/stella
88%{_bindir}/mailmaint
89%{_bindir}/listmaint
90%{_bindir}/dcmmaint
91%{_bindir}/usermaint
92%{_bindir}/update_test
[1396]93%defattr(-,root,root)
[1394]94%doc %{_mandir}/man1/*
95%doc %{_mandir}/man8/mrtest.8.gz
96
97
[1396]98# update-server
99%package update-server
[1394]100Summary: Athena update_server
101Group: Applications/System
[1397]102# Might need mit-zephyr-devel
103# Requires: mit-zephyr
[1394]104Requires(post): chkconfig
105Requires(preun): chkconfig
[1396]106%description update-server
[1394]107Moira is the Athena Service Management system.  It serves as the
108central repository for information about users, groups hosts, print
109queues, and several other aspects of the Athena environment.
110
111This package contains the update_server daemon, which is used for
112servers that automatically receive information dumps from moira.
113
[1396]114%files update-server
[1394]115%defattr(-,root,root)
116%doc %{_mandir}/man8/update_server.8.gz
117%config(noreplace) %{_sysconfdir}/athena/moira.conf
118%defattr(755,root,root)
119%{_sbindir}/update_server
120%{_initddir}/moira-update-server
121
[1396]122%post update-server
[1394]123/sbin/chkconfig --add moira-update-server
[1396]124%{_initddir}/moira-update-server condrestart
[1394]125
[1396]126%preun update-server
[1394]127if [ $1 = 0 ] ; then
128    /sbin/service moira-update-server stop >/dev/null 2>&1
129    /sbin/chkconfig --del moira-update-server
130fi
131
132# libmoira0
[1396]133%package -n libmoira0
[1394]134Summary: The Moira library
135Group: System Environment/Libraries
[1396]136%description -n libmoira0
[1394]137Moira is the Athena Service Management system.  It serves as the
138central repository for information about users, groups hosts, print
139queues, and several other aspects of the Athena environment.
140
141This package contains the shared Moira library.
142
[1396]143%post -n libmoira0 -p /sbin/ldconfig
144%postun -n libmoira0 -p /sbin/ldconfig
145
146%files -n libmoira0
147%defattr(-,root,root)
[1394]148%{_libdir}/libmoira.so.*
149
[1396]150# libmoira-devel
151%package -n libmoira-devel
[1394]152Summary: Development files for Moira library
153Group: Development/Libraries
[1397]154# Might need mit-zephyr-devel
155# Requires: mit-zephyr
156Requires: libmoira0 = %{version}-%{release}, e2fsprogs-devel, krb5-devel, hesiod-devel
[1396]157%description -n libmoira-devel
[1394]158Moira is the Athena Service Management system.  It serves as the
159central repository for information about users, groups hosts, print
160queues, and several other aspects of the Athena environment.
161
162This package contains headers and static libraries for development.
163
[1396]164%post -n libmoira-devel -p /sbin/ldconfig
165%postun -n libmoira-devel -p /sbin/ldconfig
166
167%files -n libmoira-devel
[1394]168%defattr(-,root,root)
169%{_includedir}/*
170%doc %{_mandir}/man3/*
171%{_libdir}/libmoira.so
172%{_libdir}/libmoira.la
173%{_libdir}/libmoira.a
[1396]174
175%changelog
[1403]176* Mon Dec 28 2009 Mitchell Berger <mitchb@mit.edu> - 4.0.0-2.1402.cvs20091228
177- Update to new upstream version, including eunice printer client
178
[1396]179* Sat Dec 26 2009 Greg Brockman <gdb@mit.edu> - 4.0.0-2.1380.cvs20091116
180- Initial packaging of Moira on Fedora
Note: See TracBrowser for help on using the repository browser.