source: trunk/server/fedora/specs/httpd.spec.patch @ 2538

Last change on this file since 2538 was 2377, checked in by achernya, 10 years ago
Update to httpd 2.2.23
File size: 2.5 KB
  • /tmp/httpd/httpd.spec

    old new  
    99Summary: Apache HTTP Server
    1010Name: httpd
    1111Version: 2.2.23
    12 Release: 1%{?dist}
     12Release: 1%{?dist}.scripts.%{scriptsversion}
    1313URL: http://httpd.apache.org/
    1414Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
    1515Source1: index.html
     
    5757Requires(postun): systemd-units
    5858Requires(post): systemd-units
    5959
     60Provides: scripts-httpd = %{version}-%{release}
     61Patch1000: httpd-suexec-scripts.patch
     62Patch1003: httpd-2.2.x-mod_status-security.patch
     63Patch1004: httpd-2.2.x-304.patch
     64Patch1005: httpd-2.2.x-mod_ssl-sessioncaching.patch
     65Patch1006: httpd-suexec-cloexec.patch
     66Patch1007: httpd-fixup-vhost.patch
     67Patch1008: httpd-SSLCompression.patch
     68
    6069%description
    6170The Apache HTTP Server is a powerful, efficient, and extensible
    6271web server.
     
    6776Obsoletes: secureweb-devel, apache-devel, stronghold-apache-devel
    6877Requires: apr-devel, apr-util-devel, pkgconfig
    6978Requires: httpd = %{version}-%{release}
     79Provides: scripts-httpd-devel = %{version}-%{release}
    7080
    7181%description devel
    7282The httpd-devel package contains the APXS binary and other files
     
    105115Requires(post): openssl, /bin/cat
    106116Requires(pre): httpd
    107117Requires: httpd = 0:%{version}-%{release}, httpd-mmn = %{mmnisa}
     118Provides: scripts-mod_ssl
    108119Obsoletes: stronghold-mod_ssl
    109120
    110121%description -n mod_ssl
     
    131142# Patch in vendor/release string
    132143sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
    133144
     145%patch1000 -p1 -b .scripts
     146%patch1003 -p1 -b .permitstatus
     147%patch1004 -p1 -b .scripts-304
     148%patch1005 -p1 -b .ssl-sessioncache
     149%patch1006 -p1 -b .cloexec
     150%patch1007 -p1 -b .fixup-vhost
     151%patch1008 -p1 -b .sslcompression
     152
    134153# Safety check: prevent build if defined MMN does not equal upstream MMN.
    135154vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
    136155if test "x${vmmn}" != "x%{mmn}"; then
     
    191210        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
    192211        --enable-suexec --with-suexec \
    193212        --with-suexec-caller=%{suexec_caller} \
    194         --with-suexec-docroot=%{contentdir} \
     213        --with-suexec-docroot=/ \
     214        --with-suexec-userdir=web_scripts \
     215        --with-suexec-trusteddir=/usr/libexec/scripts-trusted \
    195216        --with-suexec-logfile=%{_localstatedir}/log/httpd/suexec.log \
    196217        --with-suexec-bin=%{_sbindir}/suexec \
    197         --with-suexec-uidmin=500 --with-suexec-gidmin=100 \
     218        --with-suexec-uidmin=50 --with-suexec-gidmin=50 \
    198219        --enable-pie \
    199220        --with-pcre \
    200221        $*
Note: See TracBrowser for help on using the repository browser.