source: trunk/server/fedora/specs/httpd.spec.patch @ 1761

Last change on this file since 1761 was 1738, checked in by ezyang, 12 years ago
Trivial update to httpd.spec.diff for latest version.
File size: 2.4 KB
  • httpd.spec

    old new  
    77Summary: Apache HTTP Server
    88Name: httpd
    99Version: 2.2.17
    10 Release: 1%{?dist}.1
     10Release: 1%{?dist}.1.scripts.%{scriptsversion}
    1111URL: http://httpd.apache.org/
    1212Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.bz2
    1313Source1: index.html
     
    5555Conflicts: pcre < 4.0
    5656Requires: httpd-tools = %{version}-%{release}, apr-util-ldap
    5757
     58Provides: scripts-httpd
     59Patch1000: httpd-suexec-scripts.patch
     60Patch1003: httpd-2.2.x-mod_status-security.patch
     61Patch1004: httpd-2.2.x-304.patch
     62Patch1005: httpd-2.2.x-mod_ssl-sessioncaching.patch
     63Patch1006: httpd-suexec-cloexec.patch
     64Patch1007: httpd-fixup-vhost.patch
     65
    5866%description
    5967The Apache HTTP Server is a powerful, efficient, and extensible
    6068web server.
     
    6573Obsoletes: secureweb-devel, apache-devel, stronghold-apache-devel
    6674Requires: apr-devel, apr-util-devel, pkgconfig
    6775Requires: httpd = %{version}-%{release}
     76Provides: scripts-httpd-devel
    6877
    6978%description devel
    7079The httpd-devel package contains the APXS binary and other files
     
    103112Requires(post): openssl >= 0.9.7f-4, /bin/cat
    104113Requires(pre): httpd
    105114Requires: httpd = 0:%{version}-%{release}, httpd-mmn = %{mmn}
     115Provides: scripts-mod_ssl
    106116Obsoletes: stronghold-mod_ssl
    107117
    108118%description -n mod_ssl
     
    130140# Patch in vendor/release string
    131141sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
    132142
     143%patch1000 -p1 -b .scripts
     144%patch1003 -p1 -b .permitstatus
     145%patch1004 -p1 -b .scripts-304
     146%patch1005 -p1 -b .ssl-sessioncache
     147%patch1006 -p1 -b .cloexec
     148%patch1007 -p1 -b .fixup-vhost
     149
    133150# Safety check: prevent build if defined MMN does not equal upstream MMN.
    134151vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
    135152if test "x${vmmn}" != "x%{mmn}"; then
     
    177194        --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
    178195        --enable-suexec --with-suexec \
    179196        --with-suexec-caller=%{suexec_caller} \
    180         --with-suexec-docroot=%{contentdir} \
     197        --with-suexec-docroot=/ \
     198        --with-suexec-userdir=web_scripts \
     199        --with-suexec-trusteddir=/usr/libexec/scripts-trusted \
    181200        --with-suexec-logfile=%{_localstatedir}/log/httpd/suexec.log \
    182201        --with-suexec-bin=%{_sbindir}/suexec \
    183         --with-suexec-uidmin=500 --with-suexec-gidmin=100 \
     202        --with-suexec-uidmin=50 --with-suexec-gidmin=50 \
    184203        --enable-pie \
    185204        --with-pcre \
    186205        $*
Note: See TracBrowser for help on using the repository browser.