source: trunk/server/fedora/specs/ghc-unix-handle.spec @ 1710

Last change on this file since 1710 was 1693, checked in by ezyang, 13 years ago
Merge Fedora 13 development back to trunk.
File size: 1.6 KB
RevLine 
[1590]1%global pkg_name unix-handle
2
[1693]3%global common_summary Haskell %{pkg_name} library
[1590]4
[1693]5%global common_description A %{pkg_name} library for Haskell.
6
7# add any Haskell library dependencies here:
8#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
9
10# add any foreign library dependencies here:
11#%%global ghc_pkg_c_deps @CDEP1@-devel
12
13%bcond_without shared
14
15# debuginfo is not useful for ghc
[1590]16%global debug_package %{nil}
17
18Name:           ghc-%{pkg_name}
19Version:        0.0.0
20Release:        0.%{scriptsversion}%{?dist}
[1693]21Summary:        %{common_summary}
[1590]22
[1693]23Group:          System Environment/Libraries
[1590]24License:        BSD
25URL:            http://hackage.haskell.org/cgi-bin/hackage-scripts/package/%{pkg_name}
26Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
27BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
28# fedora ghc archs:
29ExclusiveArch:  %{ix86} x86_64 ppc alpha
[1693]30BuildRequires:  ghc, ghc-doc, ghc-prof
31BuildRequires:  ghc-rpm-macros >= 0.7.0
32%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
33%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
[1590]34
35%description
[1693]36%{common_description}
37%if %{with shared}
38This package provides the shared library.
[1590]39%endif
40
41
[1693]42%{?ghc_lib_package}
[1590]43
44
45%prep
46%setup -q -n %{pkg_name}-%{version}
47
48
49%build
[1693]50%ghc_lib_build
[1590]51
52
53%install
54rm -rf $RPM_BUILD_ROOT
[1693]55%ghc_lib_install
[1590]56
57
58%clean
59rm -rf $RPM_BUILD_ROOT
60
61
62%changelog
[1693]63* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0
64- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.