[1590] | 1 | %global pkg_name MonadCatchIO-mtl |
---|
| 2 | |
---|
[1693] | 3 | %global common_summary Haskell %{pkg_name} library |
---|
[1590] | 4 | |
---|
[1693] | 5 | %global common_description A %{pkg_name} library for Haskell. |
---|
| 6 | |
---|
| 7 | # add any Haskell library dependencies here: |
---|
| 8 | %global ghc_pkg_deps ghc-mtl-devel |
---|
| 9 | |
---|
| 10 | # add any foreign library dependencies here: |
---|
| 11 | #%%global ghc_pkg_c_deps @CDEP1@-devel |
---|
| 12 | |
---|
| 13 | %bcond_without shared |
---|
| 14 | |
---|
| 15 | # debuginfo is not useful for ghc |
---|
[1590] | 16 | %global debug_package %{nil} |
---|
| 17 | |
---|
| 18 | Name: ghc-%{pkg_name} |
---|
| 19 | Version: 0.3.0.1 |
---|
| 20 | Release: 0.%{scriptsversion}%{?dist} |
---|
[1693] | 21 | Summary: %{common_summary} |
---|
[1590] | 22 | |
---|
[1693] | 23 | Group: System Environment/Libraries |
---|
[1590] | 24 | License: BSD |
---|
| 25 | URL: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/%{pkg_name} |
---|
| 26 | Source0: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz |
---|
| 27 | BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
---|
| 28 | # fedora ghc archs: |
---|
| 29 | ExclusiveArch: %{ix86} x86_64 ppc alpha |
---|
[1693] | 30 | BuildRequires: ghc, ghc-doc, ghc-prof |
---|
| 31 | BuildRequires: ghc-rpm-macros >= 0.7.0 |
---|
| 32 | %{?ghc_pkg_deps:BuildRequires: %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")} |
---|
| 33 | %{?ghc_pkg_c_deps:BuildRequires: %{ghc_pkg_c_deps}} |
---|
[1590] | 34 | |
---|
| 35 | %description |
---|
[1693] | 36 | %{common_description} |
---|
| 37 | %if %{with shared} |
---|
| 38 | This package provides the shared library. |
---|
[1590] | 39 | %endif |
---|
| 40 | |
---|
| 41 | |
---|
[1693] | 42 | %{?ghc_lib_package} |
---|
[1590] | 43 | |
---|
| 44 | |
---|
| 45 | %prep |
---|
| 46 | %setup -q -n %{pkg_name}-%{version} |
---|
| 47 | |
---|
| 48 | |
---|
| 49 | %build |
---|
[1693] | 50 | %ghc_lib_build |
---|
[1590] | 51 | |
---|
| 52 | |
---|
| 53 | %install |
---|
| 54 | rm -rf $RPM_BUILD_ROOT |
---|
[1693] | 55 | %ghc_lib_install |
---|
[1590] | 56 | |
---|
| 57 | |
---|
| 58 | %clean |
---|
| 59 | rm -rf $RPM_BUILD_ROOT |
---|
| 60 | |
---|
| 61 | |
---|
| 62 | %changelog |
---|
[1693] | 63 | * Thu Sep 9 2010 Anders Kaseorg <andersk@mit.edu> - 0.3.0.1-0 |
---|
| 64 | - initial packaging for Fedora automatically generated by cabal2spec-0.22.1 |
---|