source: trunk/server/common/patches/rubygems-rails-require-thread.patch @ 2183

Last change on this file since 2183 was 2066, checked in by achernya, 12 years ago
Merge branches/fc15-dev to trunk
File size: 455 bytes
RevLine 
[2025]1--- a/lib/rubygems.rb.orig      2011-11-04 14:20:28.000000000 -0400
2+++ b/lib/rubygems.rb   2011-11-04 14:22:00.000000000 -0400
3@@ -30,6 +30,10 @@
4 require 'rbconfig'
5 require "rubygems/deprecate"
6 
7+# HACK: this is here just for rails, see
8+# http://stackoverflow.com/questions/5176782/uninitialized-constant-activesupportdependenciesmutex-nameerror
9+require "thread"
10+
11 ##
12 # RubyGems is the Ruby standard for publishing and managing third party
13 # libraries.
Note: See TracBrowser for help on using the repository browser.