source: server/fedora/specs/httpd.spec.patch @ 1119

Last change on this file since 1119 was 1035, checked in by mitchb, 14 years ago
Fix "the-bug" (non-empty content in 304s) in PHP (patch by ezyang) and Apache PHP should not produce any output, even if zlib.output_compression is on, if the HTTP response code is 204 or 304 (no content or not modified). Fixes PHP bug #42362 with php.cvs #56693, see: http://bugs.php.net/bug.php?id=42362 http://news.php.net/php.cvs/56693 http://cvs.php.net/viewvc.cgi/php-src/ext/zlib/zlib.c?r1=1.183.2.6.2.5.2.9&r2=1.183.2.6.2.5.2.10 Apache should discard any body provided by a script (in any language, not just PHP) when the status is "no content" or "not modified". Addresses part of Apache bug #40953, see: https://issues.apache.org/bugzilla/show_bug.cgi?id=40953#c7 Solves scripts.mit.edu support issue #773060, see: https://help.mit.edu/Ticket/UpdateCallCenter.html?id=773060 https://diswww.mit.edu/charon/scripts/24018
File size: 2.0 KB
RevLine 
[1034]1--- httpd.spec.orig     2009-03-28 13:32:47.000000000 -0400
[1035]2+++ httpd.spec  2009-03-28 14:20:15.000000000 -0400
[1033]3@@ -6,7 +6,7 @@
[926]4 Summary: Apache HTTP Server
5 Name: httpd
[1034]6 Version: 2.2.10
[1033]7-Release: 1%{?dist}
8+Release: 1%{?dist}.scripts.%{scriptsversion}
[926]9 URL: http://httpd.apache.org/
10 Source0: http://www.apache.org/dist/httpd/httpd-%{version}.tar.gz
11 Source1: index.html
[1035]12@@ -54,6 +54,12 @@
[1]13 Conflicts: pcre < 4.0
[760]14 Requires: httpd-tools = %{version}-%{release}
[1]15 
[925]16+Provides: scripts-httpd
[1]17+Patch1000: httpd-suexec-scripts.patch
[816]18+Patch1001: httpd-2.2.x-sni.patch
[795]19+Patch1003: httpd-2.2.x-mod_status-security.patch
[1035]20+Patch1004: httpd-2.2.x-304.patch
[1]21+
22 %description
23 The Apache HTTP Server is a powerful, efficient, and extensible
24 web server.
[1035]25@@ -100,6 +106,7 @@
[925]26 BuildRequires: openssl-devel, distcache-devel
27 Requires(post): openssl >= 0.9.7f-4, /bin/cat
28 Requires: httpd = 0:%{version}-%{release}, httpd-mmn = %{mmn}
29+Provides: scripts-mod_ssl
30 Obsoletes: stronghold-mod_ssl
31 
32 %description -n mod_ssl
[1035]33@@ -127,6 +134,11 @@
[1]34 # Patch in vendor/release string
35 sed "s/@RELEASE@/%{vstring}/" < %{PATCH20} | patch -p1
36 
37+%patch1000 -p1 -b .scripts
[683]38+%patch1001 -p1 -b .sni
[795]39+%patch1003 -p1 -b .permitstatus
[1035]40+%patch1004 -p1 -b .scripts-304
[1]41+
42 # Safety check: prevent build if defined MMN does not equal upstream MMN.
43 vmmn=`echo MODULE_MAGIC_NUMBER_MAJOR | cpp -include include/ap_mmn.h | sed -n '/^2/p'`
44 if test "x${vmmn}" != "x%{mmn}"; then
[1035]45@@ -175,10 +187,12 @@
[684]46         --with-apr=%{_prefix} --with-apr-util=%{_prefix} \
47        --enable-suexec --with-suexec \
48        --with-suexec-caller=%{suexec_caller} \
49-       --with-suexec-docroot=%{contentdir} \
50+       --with-suexec-docroot=/ \
51+       --with-suexec-userdir=web_scripts \
[824]52+       --with-suexec-trusteddir=/usr/libexec/scripts-trusted \
[684]53        --with-suexec-logfile=%{_localstatedir}/log/httpd/suexec.log \
54        --with-suexec-bin=%{_sbindir}/suexec \
55-       --with-suexec-uidmin=500 --with-suexec-gidmin=100 \
56+       --with-suexec-uidmin=50 --with-suexec-gidmin=50 \
57         --enable-pie \
58         --with-pcre \
59        $*
Note: See TracBrowser for help on using the repository browser.