source: server/fedora/specs/execsys.spec @ 969

Last change on this file since 969 was 926, checked in by quentin, 15 years ago
Use an RPM macro instead of sed to specify package versions
File size: 1.7 KB
RevLine 
[1]1Summary: scripts.mit.edu glue associated with file execution
2Group: Applications/System
3Name: execsys
[926]4Version: 0.%{scriptsversion}
[120]5Release: 0
[1]6Vendor: The scripts.mit.edu Team (scripts@mit.edu)
7URL: http://scripts.mit.edu
8License: GPL
[859]9Requires: xinetd
[89]10Source: %{name}.tar.gz
[1]11BuildRoot: %{_tmppath}/%(%{__id_u} -n)-%{name}-%{version}-root
12%define debug_package %{nil}
13
[89]14%description
[1]15
16scripts.mit.edu glue associated with file execution
17Contains:
18 - Apache configuration file <execsys.conf>
19 - binfmt_misc init script <execsys-binfmt>
[104]20 - Binary for serving static content <static-cat>
[1]21See http://scripts.mit.edu/wiki for more information.
22
23%prep
24%setup -q -n %{name}
25
26%build
[825]27./configure --prefix=/usr/local --with-pl=/usr/bin/perl --with-php=/usr/bin/php-cgi --with-py=/usr/bin/python --with-exe=/usr/bin/mono
[89]28make SYSCATDIR=/usr/local/sbin
[1]29
30%install
31[ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
[825]32make install DESTDIR=$RPM_BUILD_ROOT SYSCATDIR=/usr/local/sbin
[1]33
34%clean
35[ $RPM_BUILD_ROOT != / ] && rm -rf $RPM_BUILD_ROOT
36
37%files
38%defattr(0644, root, root)
39/etc/httpd/conf.d/execsys.conf
40%defattr(0755, root, root)
[104]41/usr/local/bin/static-cat
[1]42/etc/init.d/execsys-binfmt
[849]43/usr/local/sbin/ldapize.pl
[825]44/usr/local/sbin/svnproxy.pl
45/usr/libexec/scripts-trusted/svn
46/etc/xinetd.d/scripts-svn
[849]47/usr/local/sbin/gitproxy.pl
48/usr/libexec/scripts-trusted/git
49/etc/xinetd.d/scripts-git
[1]50
[27]51%post
52chkconfig --add execsys-binfmt
53service execsys-binfmt start
[825]54service xinetd reload
[27]55
56%preun
[922]57if [ "$1" = "0" ] ; then
58   service execsys-binfmt stop
59   chkconfig --del execsys-binfmt
60fi
[27]61
[825]62%postun
63service xinetd reload
64
[1]65%changelog
[922]66* Wed Dec 31 2008  Quentin Smith <quentin@mit.edu>
67- don't stop execsys on package updates
[1]68
69* Sat Sep 30 2006  Jeff Arnold <jbarnold@MIT.EDU> 0.00
70- initial prerelease version
Note: See TracBrowser for help on using the repository browser.