1 | # https://fedoraproject.org/wiki/Packaging:Haskell |
---|
2 | |
---|
3 | %global pkg_name unix-handle |
---|
4 | |
---|
5 | Name: ghc-%{pkg_name} |
---|
6 | Version: 0.0.0 |
---|
7 | Release: 0.%{scriptsversion}%{?dist} |
---|
8 | Summary: POSIX operations on Handles |
---|
9 | |
---|
10 | License: BSD |
---|
11 | URL: http://hackage.haskell.org/package/%{pkg_name} |
---|
12 | Source0: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz |
---|
13 | |
---|
14 | BuildRequires: ghc-Cabal-devel |
---|
15 | BuildRequires: ghc-rpm-macros %{!?without_hscolour:hscolour} |
---|
16 | # Begin cabal-rpm deps: |
---|
17 | BuildRequires: ghc-unix-devel |
---|
18 | # End cabal-rpm deps |
---|
19 | |
---|
20 | %description |
---|
21 | This package provides versions of functions from "System.Posix.Files" that |
---|
22 | operate on 'System.IO.Handle' instead of 'System.IO.FilePath' or |
---|
23 | 'System.Posix.Fd'. This is useful to prevent race conditions that may arise |
---|
24 | from looking up the same path twice. |
---|
25 | |
---|
26 | |
---|
27 | %package devel |
---|
28 | Summary: Haskell %{pkg_name} library development files |
---|
29 | Provides: %{name}-static = %{version}-%{release} |
---|
30 | Requires: ghc-compiler = %{ghc_version} |
---|
31 | Requires(post): ghc-compiler = %{ghc_version} |
---|
32 | Requires(postun): ghc-compiler = %{ghc_version} |
---|
33 | Requires: %{name}%{?_isa} = %{version}-%{release} |
---|
34 | |
---|
35 | %description devel |
---|
36 | This package provides the Haskell %{pkg_name} library development files. |
---|
37 | |
---|
38 | |
---|
39 | %prep |
---|
40 | %setup -q -n %{pkg_name}-%{version} |
---|
41 | |
---|
42 | |
---|
43 | %build |
---|
44 | %ghc_lib_build |
---|
45 | |
---|
46 | |
---|
47 | %install |
---|
48 | %ghc_lib_install |
---|
49 | |
---|
50 | |
---|
51 | %post devel |
---|
52 | %ghc_pkg_recache |
---|
53 | |
---|
54 | |
---|
55 | %postun devel |
---|
56 | %ghc_pkg_recache |
---|
57 | |
---|
58 | |
---|
59 | %files -f %{name}.files |
---|
60 | %doc LICENSE |
---|
61 | |
---|
62 | |
---|
63 | %files devel -f %{name}-devel.files |
---|
64 | |
---|
65 | |
---|
66 | %changelog |
---|
67 | * Mon May 26 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.0.0-0 |
---|
68 | - Updated packaging for F20 with cabal-rpm |
---|
69 | |
---|
70 | * Fri May 25 2012 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0 |
---|
71 | - regenerated packaging with cabal2spec-0.25.5 |
---|
72 | |
---|
73 | * Mon May 2 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0 |
---|
74 | - regenerated packaging with cabal2spec-0.22.5 |
---|
75 | |
---|
76 | * Thu Sep 9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0 |
---|
77 | - initial packaging for Fedora automatically generated by cabal2spec-0.22.1 |
---|