[2246] | 1 | # https://fedoraproject.org/wiki/Packaging:Haskell |
---|
[2066] | 2 | |
---|
[1590] | 3 | %global pkg_name unix-handle |
---|
| 4 | |
---|
| 5 | Name: ghc-%{pkg_name} |
---|
| 6 | Version: 0.0.0 |
---|
| 7 | Release: 0.%{scriptsversion}%{?dist} |
---|
[2525] | 8 | Summary: POSIX operations on Handles |
---|
[1590] | 9 | |
---|
| 10 | License: BSD |
---|
[2066] | 11 | URL: http://hackage.haskell.org/package/%{pkg_name} |
---|
[1590] | 12 | Source0: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz |
---|
[2525] | 13 | |
---|
[2246] | 14 | BuildRequires: ghc-Cabal-devel |
---|
| 15 | BuildRequires: ghc-rpm-macros %{!?without_hscolour:hscolour} |
---|
[2525] | 16 | # Begin cabal-rpm deps: |
---|
| 17 | BuildRequires: ghc-unix-devel |
---|
| 18 | # End cabal-rpm deps |
---|
[1590] | 19 | |
---|
| 20 | %description |
---|
[2525] | 21 | This package provides versions of functions from "System.Posix.Files" that |
---|
| 22 | operate on 'System.IO.Handle' instead of 'System.IO.FilePath' or |
---|
| 23 | 'System.Posix.Fd'. This is useful to prevent race conditions that may arise |
---|
| 24 | from looking up the same path twice. |
---|
[1590] | 25 | |
---|
| 26 | |
---|
[2525] | 27 | %package devel |
---|
| 28 | Summary: Haskell %{pkg_name} library development files |
---|
| 29 | Provides: %{name}-static = %{version}-%{release} |
---|
| 30 | Requires: ghc-compiler = %{ghc_version} |
---|
| 31 | Requires(post): ghc-compiler = %{ghc_version} |
---|
| 32 | Requires(postun): ghc-compiler = %{ghc_version} |
---|
| 33 | Requires: %{name}%{?_isa} = %{version}-%{release} |
---|
| 34 | |
---|
| 35 | %description devel |
---|
| 36 | This package provides the Haskell %{pkg_name} library development files. |
---|
| 37 | |
---|
| 38 | |
---|
[1590] | 39 | %prep |
---|
| 40 | %setup -q -n %{pkg_name}-%{version} |
---|
| 41 | |
---|
| 42 | |
---|
| 43 | %build |
---|
[1693] | 44 | %ghc_lib_build |
---|
[1590] | 45 | |
---|
| 46 | |
---|
| 47 | %install |
---|
[1693] | 48 | %ghc_lib_install |
---|
[1590] | 49 | |
---|
| 50 | |
---|
[2525] | 51 | %post devel |
---|
| 52 | %ghc_pkg_recache |
---|
[1590] | 53 | |
---|
| 54 | |
---|
[2525] | 55 | %postun devel |
---|
| 56 | %ghc_pkg_recache |
---|
[2246] | 57 | |
---|
| 58 | |
---|
[2525] | 59 | %files -f %{name}.files |
---|
| 60 | %doc LICENSE |
---|
[2246] | 61 | |
---|
| 62 | |
---|
[2525] | 63 | %files devel -f %{name}-devel.files |
---|
[2246] | 64 | |
---|
[2525] | 65 | |
---|
[1590] | 66 | %changelog |
---|
[2525] | 67 | * Mon May 26 2014 Alex Chernyakhovsky <achernya@mit.edu> - 0.0.0-0 |
---|
| 68 | - Updated packaging for F20 with cabal-rpm |
---|
| 69 | |
---|
[2246] | 70 | * Fri May 25 2012 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0 |
---|
| 71 | - regenerated packaging with cabal2spec-0.25.5 |
---|
| 72 | |
---|
[2066] | 73 | * Mon May 2 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.0.0-0 |
---|
| 74 | - regenerated packaging with cabal2spec-0.22.5 |
---|
| 75 | |
---|
[1693] | 76 | * Thu Sep 9 2010 Anders Kaseorg <andersk@mit.edu> - 0.0.0-0 |
---|
| 77 | - initial packaging for Fedora automatically generated by cabal2spec-0.22.1 |
---|