1 | # For Haskell Packaging Guidelines see: |
---|
2 | # - https://fedoraproject.org/wiki/Packaging:Haskell |
---|
3 | # - https://fedoraproject.org/wiki/PackagingDrafts/Haskell |
---|
4 | |
---|
5 | %global pkg_name MonadCatchIO-mtl |
---|
6 | |
---|
7 | # common part of summary for all the subpackages |
---|
8 | %global common_summary Haskell %{pkg_name} library |
---|
9 | |
---|
10 | # main description used for all the subpackages |
---|
11 | %global common_description A %{pkg_name} library for Haskell. |
---|
12 | |
---|
13 | # add any Haskell library dependencies here: |
---|
14 | %global ghc_pkg_deps ghc-mtl-devel |
---|
15 | |
---|
16 | # Haskell library dependencies (used for buildrequires and devel/prof subpkg requires) |
---|
17 | #%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel |
---|
18 | |
---|
19 | # foreign library dependencies (used for buildrequires and devel subpkg requires) |
---|
20 | #%%global ghc_pkg_c_deps @CDEP1@-devel |
---|
21 | |
---|
22 | %bcond_without shared |
---|
23 | |
---|
24 | # debuginfo is not useful for ghc |
---|
25 | %global debug_package %{nil} |
---|
26 | |
---|
27 | Name: ghc-%{pkg_name} |
---|
28 | Version: 0.3.0.2 |
---|
29 | Release: 1.%{scriptsversion}%{?dist} |
---|
30 | Summary: %{common_summary} |
---|
31 | |
---|
32 | Group: System Environment/Libraries |
---|
33 | License: @LICENSE@ |
---|
34 | URL: http://hackage.haskell.org/package/%{pkg_name} |
---|
35 | Source0: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz |
---|
36 | # fedora ghc archs: |
---|
37 | ExclusiveArch: %{ix86} x86_64 ppc alpha sparcv9 |
---|
38 | BuildRequires: ghc, ghc-doc, ghc-prof |
---|
39 | # macros for building haskell packages |
---|
40 | BuildRequires: ghc-rpm-macros >= 0.7.3 |
---|
41 | BuildRequires: hscolour |
---|
42 | %{?ghc_pkg_deps:BuildRequires: %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")} |
---|
43 | %{?ghc_pkg_c_deps:BuildRequires: %{ghc_pkg_c_deps}} |
---|
44 | |
---|
45 | %description |
---|
46 | %{common_description} |
---|
47 | |
---|
48 | |
---|
49 | %prep |
---|
50 | %setup -q -n %{pkg_name}-%{version} |
---|
51 | |
---|
52 | |
---|
53 | %build |
---|
54 | %ghc_lib_build |
---|
55 | |
---|
56 | |
---|
57 | %install |
---|
58 | %ghc_lib_install |
---|
59 | |
---|
60 | |
---|
61 | # define the devel and prof subpkgs, devel post[un] scripts, and filelists: |
---|
62 | # ghc-%pkg_name{,devel,prof}.files |
---|
63 | %ghc_lib_package |
---|
64 | |
---|
65 | |
---|
66 | %changelog |
---|
67 | * Sat Apr 16 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.3.0.2-1 |
---|
68 | - regenerated packaging for Fedora automatically generated by cabal2spec-0.22.5 |
---|
69 | |
---|
70 | * Thu Sep 9 2010 Anders Kaseorg <andersk@mit.edu> - 0.3.0.1-0 |
---|
71 | - initial packaging for Fedora automatically generated by cabal2spec-0.22.1 |
---|