[1840] | 1 | # For Haskell Packaging Guidelines see: |
---|
| 2 | # - https://fedoraproject.org/wiki/Packaging:Haskell |
---|
| 3 | # - https://fedoraproject.org/wiki/PackagingDrafts/Haskell |
---|
| 4 | |
---|
[1590] | 5 | %global pkg_name MonadCatchIO-mtl |
---|
| 6 | |
---|
[1840] | 7 | # common part of summary for all the subpackages |
---|
[1693] | 8 | %global common_summary Haskell %{pkg_name} library |
---|
[1590] | 9 | |
---|
[1840] | 10 | # main description used for all the subpackages |
---|
[1693] | 11 | %global common_description A %{pkg_name} library for Haskell. |
---|
| 12 | |
---|
[1840] | 13 | # Haskell library dependencies (used for buildrequires and devel/prof subpkg requires) |
---|
[1693] | 14 | %global ghc_pkg_deps ghc-mtl-devel |
---|
| 15 | |
---|
[1840] | 16 | # foreign library dependencies (used for buildrequires and devel subpkg requires) |
---|
[1693] | 17 | #%%global ghc_pkg_c_deps @CDEP1@-devel |
---|
| 18 | |
---|
[1590] | 19 | Name: ghc-%{pkg_name} |
---|
[1840] | 20 | Version: 0.3.0.2 |
---|
[1839] | 21 | Release: 0.%{scriptsversion}%{?dist} |
---|
[1693] | 22 | Summary: %{common_summary} |
---|
[1590] | 23 | |
---|
[1693] | 24 | Group: System Environment/Libraries |
---|
[1833] | 25 | License: BSD |
---|
[1840] | 26 | URL: http://hackage.haskell.org/package/%{pkg_name} |
---|
[1590] | 27 | Source0: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz |
---|
| 28 | # fedora ghc archs: |
---|
[1840] | 29 | ExclusiveArch: %{ix86} x86_64 ppc alpha sparcv9 |
---|
[1693] | 30 | BuildRequires: ghc, ghc-doc, ghc-prof |
---|
[1840] | 31 | # macros for building haskell packages |
---|
| 32 | BuildRequires: ghc-rpm-macros >= 0.7.3 |
---|
| 33 | BuildRequires: hscolour |
---|
[1693] | 34 | %{?ghc_pkg_deps:BuildRequires: %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")} |
---|
| 35 | %{?ghc_pkg_c_deps:BuildRequires: %{ghc_pkg_c_deps}} |
---|
[1590] | 36 | |
---|
| 37 | %description |
---|
[1693] | 38 | %{common_description} |
---|
[1590] | 39 | |
---|
| 40 | |
---|
| 41 | %prep |
---|
| 42 | %setup -q -n %{pkg_name}-%{version} |
---|
| 43 | |
---|
| 44 | |
---|
| 45 | %build |
---|
[1693] | 46 | %ghc_lib_build |
---|
[1590] | 47 | |
---|
| 48 | |
---|
| 49 | %install |
---|
[1693] | 50 | %ghc_lib_install |
---|
[1590] | 51 | |
---|
| 52 | |
---|
[1840] | 53 | # define the devel and prof subpkgs, devel post[un] scripts, and filelists: |
---|
| 54 | # ghc-%pkg_name{,devel,prof}.files |
---|
| 55 | %ghc_lib_package |
---|
[1590] | 56 | |
---|
| 57 | |
---|
| 58 | %changelog |
---|
[1840] | 59 | * Mon May 2 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.3.0.2-0 |
---|
| 60 | - regenerated packaging with cabal2spec-0.22.5 |
---|
| 61 | |
---|
[1693] | 62 | * Thu Sep 9 2010 Anders Kaseorg <andersk@mit.edu> - 0.3.0.1-0 |
---|
| 63 | - initial packaging for Fedora automatically generated by cabal2spec-0.22.1 |
---|