source: branches/fc15-dev/server/fedora/specs/ghc-MonadCatchIO-mtl.spec @ 1830

Last change on this file since 1830 was 1826, checked in by achernya, 13 years ago
Get ghc packages to build on F15 Regenerated the .spec files with cabal2spec for the Haskell packages that are needed by Scripts, including bumping the versions to the latest ones.
File size: 2.1 KB
RevLine 
[1808]1# For Haskell Packaging Guidelines see:
2# - https://fedoraproject.org/wiki/Packaging:Haskell
3# - https://fedoraproject.org/wiki/PackagingDrafts/Haskell
4
[1590]5%global pkg_name MonadCatchIO-mtl
6
[1808]7# common part of summary for all the subpackages
[1693]8%global common_summary Haskell %{pkg_name} library
[1590]9
[1808]10# main description used for all the subpackages
[1693]11%global common_description A %{pkg_name} library for Haskell.
12
[1808]13# add any Haskell library dependencies here:
[1693]14%global ghc_pkg_deps ghc-mtl-devel
15
[1808]16# Haskell library dependencies (used for buildrequires and devel/prof subpkg requires)
17#%%global ghc_pkg_deps ghc-@DEP1@-devel, ghc-@DEP2@-devel
18
19# foreign library dependencies (used for buildrequires and devel subpkg requires)
[1693]20#%%global ghc_pkg_c_deps @CDEP1@-devel
21
22%bcond_without shared
23
24# debuginfo is not useful for ghc
[1590]25%global debug_package %{nil}
26
27Name:           ghc-%{pkg_name}
[1826]28Version:        0.3.0.2
[1808]29Release:        1.%{scriptsversion}%{?dist}
[1693]30Summary:        %{common_summary}
[1590]31
[1693]32Group:          System Environment/Libraries
[1808]33License:        @LICENSE@
34URL:            http://hackage.haskell.org/package/%{pkg_name}
[1590]35Source0:        http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
36# fedora ghc archs:
[1808]37ExclusiveArch:  %{ix86} x86_64 ppc alpha sparcv9
[1693]38BuildRequires:  ghc, ghc-doc, ghc-prof
[1808]39# macros for building haskell packages
40BuildRequires:  ghc-rpm-macros >= 0.7.3
41BuildRequires:  hscolour
[1693]42%{?ghc_pkg_deps:BuildRequires:  %{ghc_pkg_deps}, %(echo %{ghc_pkg_deps} | sed -e "s/\(ghc-[^, ]\+\)-devel/\1-doc,\1-prof/g")}
43%{?ghc_pkg_c_deps:BuildRequires:  %{ghc_pkg_c_deps}}
[1590]44
45%description
[1693]46%{common_description}
[1590]47
48
49%prep
50%setup -q -n %{pkg_name}-%{version}
51
52
53%build
[1693]54%ghc_lib_build
[1590]55
56
57%install
[1693]58%ghc_lib_install
[1590]59
60
[1808]61# define the devel and prof subpkgs, devel post[un] scripts, and filelists:
62# ghc-%pkg_name{,devel,prof}.files
63%ghc_lib_package
[1590]64
65
66%changelog
[1826]67* Sat Apr 16 2011 Alexander Chernyakhovsky <achernya@mit.edu> - 0.3.0.2-1
[1808]68- regenerated packaging for Fedora automatically generated by cabal2spec-0.22.5
69
[1693]70* Thu Sep  9 2010 Anders Kaseorg <andersk@mit.edu> - 0.3.0.1-0
71- initial packaging for Fedora automatically generated by cabal2spec-0.22.1
Note: See TracBrowser for help on using the repository browser.