source: branches/fc15-dev/host/debian/scripts-vm-host/debian/scripts-vm-host.postinst @ 1973

Last change on this file since 1973 was 1892, checked in by quentin, 13 years ago
Version 0.1 of scripts host config package
File size: 1.3 KB
Line 
1#!/bin/sh
2# postinst script for #PACKAGE#
3#
4# see: dh_installdeb(1)
5
6set -e
7
8# summary of how this script can be called:
9#        * <postinst> `configure' <most-recently-configured-version>
10#        * <old-postinst> `abort-upgrade' <new version>
11#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12#          <new-version>
13#        * <postinst> `abort-remove'
14#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15#          <failed-install-package> <version> `removing'
16#          <conflicting-package> <version>
17# for details, see http://www.debian.org/doc/debian-policy/ or
18# the debian-policy package
19
20
21case "$1" in
22    configure)
23        debconf-set-selections <<EOF
24exim4-config    exim4/dc_eximconfig_configtype  select  mail sent by smarthost; no local mail
25exim4-config    exim4/dc_postmaster     string  scripts-root@mit.edu
26exim4-config    exim4/dc_smarthost      string  outgoing.mit.edu
27exim4-config    exim4/use_split_config  boolean false
28exim4-config    exim4/dc_minimaldns     boolean false
29EOF
30        invoke-rc.d munin-node restart
31    ;;
32
33    abort-upgrade|abort-remove|abort-deconfigure)
34    ;;
35
36    *)
37        echo "postinst called with unknown argument \`$1'" >&2
38        exit 1
39    ;;
40esac
41
42# dh_installdeb will replace this with shell code automatically
43# generated by other debhelper scripts.
44
45#DEBHELPER#
46
47exit 0
Note: See TracBrowser for help on using the repository browser.